0

Im connecting an SD card module to arduino pro with 3.3v , the card is getting initialized , but im getting an error message that FAT 32 partition is not available , but it is already in FAT 32 format , is this an voltage issue ? should i connect it to a 5v line? Ive tried it two libraries SD and sdfat libraries , im getting same results, im using 8gb memory card

0

A SD card is 3.3V.
Have you read this: Arduino.cc forum about SD Formatter ?
Perhaps it is a cheap module with bad contacts.
Perhaps your 8GB card is not compatible. Do you have another memory card ? Preferably older and less memory.
Perhaps you use long wires, or a breadboard with bad contacts.

In most cases it should work without problem. When the initialization is okay then the wiring is probably okay. Therefor I suspect that the card itself or the partition on it, is not compatible.

  • and Ive tried formatting with SD formatter , no change .Im not using long wires since this is a closed circuit .and upto my knowledge arduino supports upto 8gb fine and good . and ive triple checked the connections , its good .Is there something with the memory ? Please do let me know If there is something – Dinesh Thiyagarajan Mar 17 '17 at 12:35
  • Could you try with another SD memory card ? Is something else connected to the MISO ? When the module has a voltage regulator, and a 3.3V and 5V pin, then you could try to power it with 5V to the 5V pin and leave the 3.3V pin of the module open. The SD card module could be broken. – Jot Mar 17 '17 at 15:32
  • @ Jot Yeah ive tried it with 16gb memory card its working ,I dont know why its not working with 8 gb memory card – Dinesh Thiyagarajan Mar 20 '17 at 4:57
  • I'm glad it is working. Some memory cards are not compatible with the Arduino SD library, it happens. – Jot Mar 21 '17 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.