0

I'd like to use an H-Bridge AND send PWM signal.

I've used this schematics: http://itp.nyu.edu/physcomp/Labs/DCMotorControl and use the PWM signal inside the enablePin. But the H_Bridge is getting very hot.

Am I wrong?

EDIT:

I'm using and H-Bridge but not for driving a motor, instead I'm driving a peltier cell (like this one: https://www.sparkfun.com/products/10080). What I'm trying to achieve is to have a fixed peltier cell and to have in the same side sometimes hot, sometimes cold. This behaviour is done by switching the positive and negative with the H-Bridge. To control how much cold and how much hot I'm using PWM.

3

Short answer: You're drawing too much current through the H-bridge.

Longer answer: The H-bridge is most efficient when fully on and that's when the chip gets rated for the maximum current. The rating also, probably, states that a heat sink is attached to the chip. Using PWM to slow down the motor decreases the current going through the bridge, but also incurs inefficiencies because the transistors / MOSFETs are partially on, and thus acting somewhat as resistors. This inefficiency manifests as heat.

So you have several options.
1. Choose a smaller motor. This reduces the overall current needed. Only feasible if this is a learning project.
2. Choose a beefier H-bridge. This increases the ratings of the bridge to handle current for this motor.
3. Add a heat-sink to the existing bridge. This will help dissipate the heat generated.

Generally I'd recommend both 2 and 3, but it depends on your ultimate goal of the project.

  • I'm not using a motor, see the edits. – nkint Aug 2 '14 at 21:12
  • 1
    Ok, but the same applies to the peltier device. You're drawing too much current through the chip. Choose a different chip for the bridge and heat-sink it. Though that may seem odd for a project with heating / cooling features, but if your bridge overheats it will stop doing what you want. – kronenpj Aug 3 '14 at 2:03
2

This L298N board with heat sink is widely available, low cost, used in many successful project with 2 amperes capacity to support reasonably large motors.

Video, tutorial, code example in:

http://www.youtube.com/watch?v=qwNvYYqBy7I

http://www.icstation.com/product_info.php?products_id=2540#.U90l_kBbIlh

http://arduino-info.wikispaces.com/MotorDrivers

http://arduino-info.wikispaces.com/ArduinoShieldL298N

  • I'm not using a motor, see the edits. – nkint Aug 2 '14 at 21:12
  • 2
    Your peltier cell is 7A, well above L293 and L298. Choose one of these, says about 10A to 12A (with some spare for safety) pololu.com/category/11/brushed-dc-motor-drivers. Software is same, motor forward/backward become hot/cold. No issue of fast brake in your case. Some 2 pins units can be used. if doubt, ask tech support of the seller and they also have excellent document at web. – EEd Aug 2 '14 at 21:21
  • Temp control is relatively slow, depending on heat capacity of load. PWM can give you very accurate temperate control at range of 0.1 degree centigrade or better. If cost is concern, use on off control if no demand for too high accuracy, by solid state relay or mechanical relay (switching time slower, lower accuracy). – EEd Aug 3 '14 at 3:03
2

Are you using the L293NE or the SN754410?

My guess it the L293NE. With this one, if you set the enable to low, it will go into "Fast motor stop". What this does is short the two pins of the motor. This will make the motor turn into a dynamo, will all the current that is being generated going through the IC. This will make the IC hot.

This also means you motors are running very inefficiently.

  • I'm not using a motor, see the edits. – nkint Aug 2 '14 at 21:11
  • Try lowering the PWM frequency to something like 1hz. – Gerben Aug 3 '14 at 8:17
2

According to data sheet from factory, L293 and L298 do not go into fast stop mode if you connect and program them as below.

They have two inputs to control direction and one ENABLE for PWM.

When PWM signal is zero, both transistors are high impedance according to page 2 of factory data in http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&ved=0CDUQFjAB&url=http%3A%2F%2Fwww.ti.com%2Flit%2Fds%2Fsymlink%2Fl293d.pdf&ei=0z7dU-G4OZPf8AX-loDQCA&usg=AFQjCNEHiZAPaBUP_j8kV3BBPstAKiFDyw&bvm=bv.72197243,d.dGc

Data sheet Page 6 of L298, PWM connects to enable. CD is 10 and 01 for direction. fast stop is CD 00 or 11 http://www.st.com/st-web-ui/static/active/en/resource/technical/document/datasheet/CD00000240.pdf

Hope it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.