0

enter image description hereAt first i was using adafruit library for connecting adafruit ssd1306 128*64 display with arduino , display was working good, since that library was using too much space i decided to switch to #include "SSD1306AsciiAvrI2c.h" , after changing the library i tried running it , but the display was not working , i tried running the example programs in the new library but no change , so i decided to switch back to the original library without changing any pin configurations , but its too is not working , does anybody know why is this happening ? any body can help me with solutions please? This is the pin configuration im using in the picture, Is there a problem with pin configuration or with the library?

  • 1
    You've posted a picture from the Adafruit website, so it's likely the correct pin configuration. However, since you haven't shown what your pin configuration is, we have to take your word that it's as shown. But, you say you have the 128x64 OLED module and the picture is the 128x32 OLED module, so who's to say your wiring is the same? Show us what you have, not what the tutorial says you should have. If you have made a mistake, we could not tell! Also, you should show the code you are using, otherwise, how can we know what is really happening? – jose can u c Mar 8 '17 at 14:27
  • @jose can u c Ya , im using 128x64 OLED module along with arduino uno , i got it figured , there was a problem with wire configuration , and now its working after ive replaced the reset pin to 12 . – Dinesh Thiyagarajan Mar 9 '17 at 5:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.