1

The error message, generated from Sublime, in its entirety...

Compiling KCT_Swimv4l...

Creating C:\Users\ken\Documents\Arduino_Build\KCT_Swimv4l\KCT_Swimv4l.ino.cpp.o...

'"avr-g++"' is not recognized as an internal or external command, operable program or batch file.

[Stino - Error 1]


This is initial install of "Arduino-like IDE".

I used the following installation procedure:

  • Install Sublime Text 3
  • From Sublime, View --> Show Console
  • From a web browser, open https://sublime.wbond.net/installation and choose Sublime Text 3 version.
  • Copy the code there to the Sublime-Console and press enter.
  • From Sublime, CTRL + Shift + P --> Type "Install" and choose "Install package"
  • Enter "Arduino" and choose "Arduino-like IDE"
  • from Arduino --> Preferences --> Select Arduino Application Folder.

Same problem with any sketch.

System Configuration:

-Windows 10 x64, current level
-Sublime Text 3 x64, build 3126
-Arduino IDE 1.8.0

github info on Stino was not helpful. Has anyone encountered this problem and found a solution for it? If not, I can open an issue there.


I have now done the following:
Uninstalled Sublime
Searched System drive and removed any remaining Sublime content
Searched System drive and removed any Stino content
Download WinAVR from http://winavr.sourceforge.net/download.html, selecting PATH option
Reinstalled Sublime Text 3 x64
Close & Reopen Sublime
From Sublime, View --> Show Console From web browser, open https://sublime.wbond.net/installation and choose Sublime Text 3 version. Copy the code there to the Sublime-Console and press enter
Close & Reopen Sublime
From Sublime, CTRL + Shift + P --> Type "Install" and choose "Install package" Enter "Arduino" and choose "Arduino-like IDE"
Close & Reopen Sublime
From Arduino --> Preferences --> Select Arduino Application Folder

On Compile, error msg is now different:
Compiling KCT_Swimv4l...
Creating C:\Users\kct\Documents\Arduino_Build\KCT_Swimv4l\KCT_Swimv4l.ino.cpp.o...
cc1plus.exe: error: unrecognized command line option "-std=gnu++11"
cc1plus.exe: error: unrecognized command line option "-flto"
[Stino - Error 1]

  • unrecognized command line option "-std=gnu++11" - sounds like the compiler you installed is too old. It looks like it is from 2010. Right now it is 2017. – Nick Gammon Feb 26 '17 at 22:46
  • @Nick Gammon This was recommendation from answer posted. Yes, this winavr copy is from 2010, as specified in answer, and the current year is now 2017. I wondered about that. Now that I have a starting point, I now see that there is a newer copy at sourceforge.net/projects/winavr, and I will try that out. – KC Tucker Feb 27 '17 at 17:11
  • @Nick_Gammon Nope, same copy. Perhaps you can suggest a direction to pursue. – KC Tucker Feb 27 '17 at 17:25
  • The avr-g++ that ships with the Arduino IDE would be more recent. For example with IDE 1.6.9 I find: avr-g++.exe (GCC) 4.8.1. That accepts -std=gnu++11 on the command-line. – Nick Gammon Feb 27 '17 at 20:51
  • I found a whole lot of binaries (.exe files) in arduino-1.6.9\hardware\tools\avr\bin where arduino-1.6.9 is my install folder. – Nick Gammon Feb 27 '17 at 20:53
0

Download WinAVR from http://winavr.sourceforge.net/download.html, install it, add(in my case, its: C:\WinAVR-20100110\bin) to PATH variable of your system(If it was left unchecked while installing), And then try to build. I hope your problem will be solved.

Update

I have installed the latest version and found no board selection option. If you want to use it, you can download an older version. from here: https://drive.google.com/file/d/0B4zy7eqONHnuajk2aXlzOTJtaDQ/view it works on older version of arduino(probably 1.5 series)

  • 1
    I have updated problem description to show last actions taken in response to suggestion. Now get different error msgs. – KC Tucker Feb 25 '17 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.