0

I bought a Tiny RTC I2C module and it doesn't work. When i run the TimeRTCSet from TIME library all i get is:

Unable to sync with the RTC
0:00:00 0 0 1970
0:00:01 1 1 1970
0:00:02 1 1 1970
0:00:03 1 1 1970
0:00:04 1 1 1970
0:00:05 1 1 1970
0:00:06 1 1 1970
0:00:07 1 1 1970

The module is connected like this:

Vin -> 5V Gnd -> Gnd SCL -> A5 SDA -> A4

I'm using arduino uno.

I tried with a simple i2c scanner, but it returned two devices!

Scanning...
I2C device found at address 0x50  !
I2C device found at address 0x68  !
done

Only the clock is connected. I tried removing the battery for night to reset it, but it didn't fix it.

Could you help me?

  • 1
    Could you please edit your question to include a link to the I2C RTC you are using. – sa_leinad Feb 24 '17 at 9:19
  • 2
    The RTC module includes a memory module which is also addressable via I2C hence the 2 addresses. Have you tried sample code like here: elecrow.com/wiki/index.php?title=Tiny_RTC – 6v6gt Feb 24 '17 at 9:23
  • 2
    Looks like the RTC is running correctly but has not been initiated with the current time? – Mikael Patel Feb 24 '17 at 9:58
0

Try using the example code from the MD_DS1307 library to find the settings on your RTC, when I first wired mine up the clock was not running and I couldn't set the time on it. After I enabled it, it worked just fine.

  • Thank you for help. I fixed the issue. It was caused by the library which I got from arduino library manager. I deleted it and downloaded the library from github. Now it works great. – Velociraptor Feb 26 '17 at 18:00
0

This issue can be fixed by deleting the library downloaded using arduino library manager and replacing it with the library from github.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.