I have used by Arduino countless times over the past few years and only after installing an update to Mac OS Sierra did the device stop showing up under the Serial Ports. Now only tty-bluetooth shows up no others. I have looked a countless threads where people suggest installing drivers or uninstalling drivers or rebooting. I have tried everything but still no device shows up.

I switched to my Windows partition using Bootcamp and lo and behold it works perfectly there but not in Mac OS. I would still like to use Mac OS to programme my Arduino. If anyone has any suggestions I would be very grateful!

  • You've already done exactly the right thing to isolate the problem - trying a different operating system on the same hardware, and the result is that this is a Mac question, not an Arduino one. (My standard advice when people have Mac problems is to remind them that "it just works", but strangely this doesn't often help.)
    – Mark Smith
    Commented Feb 18, 2017 at 8:48
  • @MarkSmith Hahaha yes it is unfortunate that in this situation 'it just works' until it doesn't.
    – jctwood
    Commented Feb 18, 2017 at 10:32
  • Thank you @Adrian Mihalko for the detailed solution. I am running on Sierra latest release, i tried all the options you mentioned in the order. But, the serial port doesn't still show up on my Arduino IDE when I connect my Wemos D1 mini chip (which uses CH340G chipset). Please help!
    – ram
    Commented Sep 23, 2017 at 8:39
  • Im trying to make that machine works and my Macbook pro 2016 with osx high sierra does see the usb serial but not UGP amazon.com/MYSWEETY-Control-Engraving-16x10x4-5cm-110V-240V/dp/… Commented Nov 30, 2017 at 1:03

1 Answer 1


Is it an original Nano or a clone?

The original Nano uses FTDI's FT232 ship, whereas clones use the CG340 USB-to-TTL chip. The former works fine straight away Mac OS Sierra, whereas the latter needs a driver.

The CG340 driver doesn't work under Mac OS Sierra. Fortunately, someone patched the driver and made it available at GitHub. There you'll also find some troubleshooting instructions that can help (hopefully).

From Adrian Mihalko's repository at GitHub:


Latest macOS Sierra-compatible driver for devices using the CH340G, CH34G or CH34X chipset. This chipset is used in several Arduino-clones.


Version 1.3 (2016-09-27) of the OEM driver for the CH34x chipset currently causes a kernel panic (a.k.a. crash) when installed on macOS Sierra. To resolve this issue, please download and install the driver in this repo.


  • Remove the old driver by issuing one of the following commands (depending on your installation):
    • sudo rm -rf /System/Library/Extensions/usb.kext
    • sudo rm -rf /Library/Extensions/usbserial.kext
  • Restart your Mac.
  • Double-click on the CH34x_Install_V1.3.pkg file.
  • Restart your Mac.
  • Plug in your device. It should now be listed under the /dev directory. Examples:
    • /dev/cu.wchusbserial1410
    • /dev/cu.wchusbserial1420


If, and only if, the device is not recognized after the installation (or you cannot install the driver), please disable System Integrity Protection:

  • Reboot your Mac into Recovery Mode by restarting your computer and holding down Command+R until the Apple logo appears on screen.
  • Open the Terminal (Applications > Utilities > Terminal).
  • In the Terminal window, type in csrutil enable --without kext (or to fully disable: csrutil disable) and press Enter.
  • Restart your Mac.

Please share this page!

Regards, Adrian Mihalko

  • Thank you for your help. It is an original Arduino Nano not a clone as far as I know.
    – jctwood
    Commented Feb 18, 2017 at 10:31
  • Where did you bought it? Was it packaged inside a box, as original Arduino products are? Did you have to install any driver when you used it for the first time? Commented Feb 18, 2017 at 10:35
  • I'm also using Mas OS Sierra and an Arduino Pro Mini (from Sparkfun) with a breakout USB-to-UART board that uses an FTDI FT232 chip. I'm using the default Apple FTDI drivers (the ones that are bundled with Sierra) and I'm having no problems whatsoever. Some people have reported problems using the manufacturer drivers after upgrading to Sierra. Some of them solved it by uninstalling the conflicting drivers and relying on the default Apple FTDI drivers instead. It's worth a try. Commented Feb 18, 2017 at 11:03
  • This works for me. I had Clone Nano. Thanks brah.
    – GeneCode
    Commented Mar 15, 2019 at 11:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.