2

I've received an Arduino Uno today only. I have zero experience prior to Arduino boards or any other micro controller. I followed every step very carefully from the setting up guide for Linux based OS, but I still can't connect the board with my Ubuntu 16.04 PC. After googling the problem I found that the device must show up as ttyACM* but I don't see any such device in /dev. Its also not listed under the command lsusb but the LED's on the board are working properly. The ON LED is turned on when I connect it with my PC and the inbuilt LED starts to blink.

This is what the IDE displays:

Arduino IDE

  • Have you tried a different cable? – Majenko Feb 17 '17 at 21:05
  • yes I have two cables – dsfx3d Feb 17 '17 at 21:06
  • @Majenko can you help me please – dsfx3d Feb 17 '17 at 21:10
  • 1
    There are two parts: the main MCU, which is working, and the USB interface which, on clones, often dies. Does it have a square or a rectangular chip next to the USB socket? – Majenko Feb 17 '17 at 21:56
  • 1
    CH340G - notoriously bad. – Majenko Feb 17 '17 at 22:05
1

You may have to add yourself to the dialout group in Ubuntu so that your user account can access the serial ports.

Then, in the Arduino IDE, the Tools->Port menu should show you options. Right now, the screenshot you gave shows that it's set for COM1, which is a Windows-style serial port naming and definitely won't work on Ubuntu.

  • I've already done that and the Port menu is grayed out. – dsfx3d Feb 17 '17 at 21:17
  • Did you log out and log back in after adding yourself to the dialout group? – jose can u c Feb 17 '17 at 21:21
  • yes I did. I even tried rebooting but nothing works – dsfx3d Feb 17 '17 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.