0

As I couldn't make my ESP8266 be programmed using an Arduino board as FTDI bridge, I decided to buy an FTDI232 board to upload code directly to ESP module via USB. However, when new I connected it to my PC and nothing happened, no new device's notification, not listed on Device Manager; then I downloaded the chip and VCP drivers, installed them, and it keeps not communicating and not even showing its port as busy at Arduino IDE. Actually, I just disabled driver signature enforcement, repeated the process but communication between FTDI and PC keeps dead.

By testing uploading code to an Arduino Micro via FTDI (no USB connected to Micro), I checked Tx/Rx signals with an oscilloscope and both were not responding.

May it be a problem of communication PC<--->FTDI board? Or could it be that FTDI's chip is fried?

Thanks.

  • did you connect the ardunio's reset to ground to use it as an "ftdi"? that's the only way i could connect to my ESP-01s before i got a handy usb socket... – dandavis Feb 17 '17 at 10:16
  • Which Arduino board did you use? I tried with connecting reset to ground on Micro, Uno and Leonardo, but any of them seemed to work. Of course I followed the tips of grounding GPIO0 while uploading code and that stuff, but no one worked (everybody in the internet who use it has success since the first attempt, that's confusing and sad) – Julio Feb 17 '17 at 19:41
  • a cheap fake uno worked fine for me; no level shifting or anything. might try uncrossing the pins. – dandavis Feb 17 '17 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.