0

I have a WS2812B LED strip (A clone of the Adafruit one I assume, it's from China via eBay) of 60 LEDs. When I got it, it was all fine - I could load the FastLED examples and they would work perfectly. I then tried to write something more custom, which didn't work for whatever reason. Upon re-loading the FastLED examples, I now get absolutely nothing from the strip.

It's being powered by an ATX computer power supply with ample amperage on 5V, and when I remove and then re-add the power connectors the strip does flash, indicating it's getting power and is capable of lighting up. It just feels like something I have done has caused it to enter a state where it won't respond to control.

I've also made sure my sketches are making it to the arduino by loading the inbuilt LED blink sketch, which works, then trying to switch back to a FastLED example which does nothing.

I'm kind of lost as to what could be wrong here.

  • Does it work if you connect data line to another pin, changing sketch to match? Is ground still connected? – James Waldby - jwpat7 Feb 3 '17 at 2:22
  • I have tried multiple pins, and yes - have ensured power, data and ground connections are solid. Very unusual. – Taz Feb 3 '17 at 2:25
  • Do you have a way to detach a front segment of LEDs, ie, attach to data a little ways into the strip? And what was the name or nature of the “something more custom” ? – James Waldby - jwpat7 Feb 3 '17 at 2:29
  • Can you check the voltage at the end of the strip? And can you look with an oscilloscope the data line after a couple of leds? – frarugi87 Feb 3 '17 at 13:50
  • If I was the kind of person who has an oscilloscope I suspect I wouldn't have managed to destroy this strip. :) Good troubleshooting info though. – Taz Feb 8 '17 at 1:36
1

Did you follow the Adafruit NeoPixels best practices guide?

You may have zapped the first NeoPixel in the group. You should be able to, fairly easily, bypass that. Each NeoPixel has to "reshape" the data for the next one along, so if you damage the first one, no data will reach the others.

I strongly suggest you follow the guidelines in the link, including the capacitor and resistor.

  • Uh, no. I have never seen that page before. As noted, I got these from eBay and instructions were not something they came with. Good to know! I'll try bypassing the first LED and using the instructions listed and get back to this question when I determine if that was it... – Taz Feb 8 '17 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.