0

I'm on a Mac, running 10.11.6 and Arduino IDE 1.8.1.

I've been prototyping some projects using an Adafruit Trinket. I was not having any problems, until at some point my Mac stopped recognizing the trinket. Somewhere within that time, I installed the Digispark board and tested that as well. I also may have made some updates to the OS version.

I've tried many things to fix it including installing the FTDI drivers, plugging and unplugging. Restarts etc. Nothing seems to fix the issue. The board shows up in the system profiler, as well as USB Prober, but does not show as an option in the Arduino IDE. I've also tried using several different cables but no dice.

It's really frustrating, I'm not sure what else I can do to track the issue down.

  • Try changing your USB cable and sometimes cables can be charge only. You can check this by plugging in another board. If you change cables make sure that cable works with at least one other board. – Joel Feb 1 '17 at 20:02
  • Did you ensure the board is in Bootloader mode? learn.adafruit.com/introducing-trinket/starting-the-bootloader – Joel Feb 1 '17 at 20:03
  • This probably isn't relevant but: There was an issue with the FDTI chip that converts USB to serial. The manufacturer enabled something in the drivers that prevented the Chinese clone chips from working. Is it possible you were using an old version of the drivers that didn't have this feature and you have upgraded to the new version? (That said I would have though Adafruit would have been using real chips, unless its an Adafruit copy) – Code Gorilla Feb 2 '17 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.