2

Today I got Arduino Leonardo to replace my Uno. I've tried running one of sketches I use on the Uno, but with no luck. When I start the upload, RX LED on the Leonardo flashes few times, and after several seconds, L LED pulsates and I get this message:

avrdude: ser_open(): can't open device "\\.\COM9": The system cannot find the file specified.

avrdude: ser_send(): write error: sorry no info avail

I've checked in Device Manager, where it says that Arduino Leonardo is on COM3, and COM3 is also set in Arduino IDE.

However, when I change COM port to 9 in Device Manager and also in Arduino IDE and then try to upload the sketch, things start to roll out like above, but this time IDE freezes for 5-10 mins on "Uploading..." part, and finally unfreezes with this message:

Found programmer: Id = "B¨J"; type = 
    Software Version = 
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?

Several more infos:

- OS: Win7 64-bit
- Arduino IDE: 1.0.5-r2
- Other serial devices: Only Bluetooth that I've manually assigned to COM200, to avoid possible conflicts.
2
  • Try deleting all the com ports in the device manager, uninstall Arduino IDE and download and install the latest version
    – imjosh
    Jul 17, 2014 at 14:48
  • You've selected leonardo in the boards menu correct?
    – BrettAM
    Jul 18, 2014 at 0:40

2 Answers 2

1

Per imjosh's suggestion, I've installed IDE version 1.5.7 BETA and that solved my problem.
Thanks!

0

I had my Olimexino 32u4 connected to Axagon USB 3.0 hub and had problems not only to flash but also to find a board. Then plugged it directly to USB 2.0 port on my laptop and it worked. If you have problems with board communicating with PC try to change USB port it is connected to and also try different USB cables.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.