1

Today I got Arduino Leonardo to replace my Uno. I've tried running one of sketches I use on the Uno, but with no luck. When I start the upload, RX LED on the Leonardo flashes few times, and after several seconds, L LED pulsates and I get this message:

avrdude: ser_open(): can't open device "\\.\COM9": The system cannot find the file specified.

avrdude: ser_send(): write error: sorry no info avail

I've checked in Device Manager, where it says that Arduino Leonardo is on COM3, and COM3 is also set in Arduino IDE.

However, when I change COM port to 9 in Device Manager and also in Arduino IDE and then try to upload the sketch, things start to roll out like above, but this time IDE freezes for 5-10 mins on "Uploading..." part, and finally unfreezes with this message:

Found programmer: Id = "B¨J"; type = 
    Software Version = 
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?

Several more infos:

- OS: Win7 64-bit
- Arduino IDE: 1.0.5-r2
- Other serial devices: Only Bluetooth that I've manually assigned to COM200, to avoid possible conflicts.
  • Try deleting all the com ports in the device manager, uninstall Arduino IDE and download and install the latest version – imjosh Jul 17 '14 at 14:48
  • You've selected leonardo in the boards menu correct? – BrettAM Jul 18 '14 at 0:40
1

Per imjosh's suggestion, I've installed IDE version 1.5.7 BETA and that solved my problem.
Thanks!

-3

I disconnected the ATMEGA328 from Arduino board then I put another and tried to program it, it worked, so I tried it again with the old ATMEGA328 and it worked too.

  • This answer does not answer the question – Greenonline Sep 14 '15 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.