4

Components

LED Lights Up Fine with USB power from the Arduino

powerful

LED Does Not Light Up with power from the Supply Module

powerless supply configuration

What am I doing wrong?

  • The Lipo battery is brand new and is charged as the terminals showed about 7.6V on my multimeter. This is confirmed by the LED on the supply module itself lighting up fine.
  • I think I can smell just a little bit of burn whenever the supply module is connected and there is power in the circuit.
  • The positive jumper wire is connected to the 5V VCC pin on the Arduino, not the VIN pin on the Arduino, not that it matters, because if I remove the Arduino from the breadboard the LED still does not light up
7

I'm not surprised you can smell burning. You have the power supply connected backwards.

You see that little + and - symbol next to the ON/OFF jumper? That's the polarity of the two runs of pins. You have the + row connected to the - rail of your breadboard (blue) and the - row connected to the (red) positive rail.

Turn the power supply around 180° and connect it to the other end of the breadboard - the rails will be the other way around then.

  • hahaha, well spotted! it works now :D – Cel Jan 12 '17 at 11:26
  • Took me a while to notice that... ;) – Majenko Jan 12 '17 at 11:26
  • 2
    "It works now", does everything still work? I won't be surprised if something is damaged (as per the burning smell)? – Paul Jan 12 '17 at 11:34
  • @Paul the components seem to have survived the ordeal as far as the LED and the Nano lighting up go, haven't done any programming test on that Nano yet .. – Cel Jan 12 '17 at 11:35
  • Too bad, if it was burning maybe it can be another question XD – dhimaspw Jan 12 '17 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.