When trying to upload to my Mega r2, it simply times out during uploading.

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

I tried burning the bootloader, but that also gave an error.

Error while burning bootloader.
avrdude: usbdev_open(): did not find any USB device "usb"

I can see the arduino in my Devices and Printers in control panel, so I don't think the board is burnt. The power light also is on. Any ideas?

  • Right COM port and serial port selected? Commented Jul 16, 2014 at 1:35
  • @AnnonomusPenguin yep.
    – nanogru
    Commented Jul 16, 2014 at 1:37
  • When you tried burning the bootloader, were you using an external programmer?
    – user2973
    Commented Jul 16, 2014 at 4:56
  • Your Arduino IDE (and the underlying avrdude inparticular) cannot communicate with the USB device on your Arduino. Your IDE is probably misconfigured, trying to access the wrong device. Mind you that device names can sometimes change, so you really want to double check how it is known to your system ,either in Device Manager (Windows), in dmesg (Linux), or similar on other platforms. On Linux/iOS you want to double check device permission settings.
    – jippie
    Commented Jul 16, 2014 at 5:54

5 Answers 5


I have seen this error numerous times before. I think the possibilities could be that either some external device is connected on RX, TX pins of arduino mega or mega is not getting sufficient power. Some connection from your board is trying to pull more than the limit current.

and off course the answers suggested above are also right. check out every possibility.


Download the devel filter.exe file from this site. Install it and target your programmer (I assume you are programming via ISP if you're using avrdude)


This will eliminate the 'USB not found' problem.


When you try to upload a sketch do the Receive and/or Transmit lights on the Arduino blink? If not you may not be getting serial communication. Try a loopback test (connect D0 to D1 and see if stuff you type in Serial Monitor comes back as it should).

If not, go to My Computer>Properties>Device Manager and search for Ports(COM&LPT)>is there Arduino MEGA??? If not you have no drivers installed or they haven't been installed automaticly or your arduino is dead :)). If it is drivers you have to update them. In same Device Manager expand Other devices. There should be some Unknown devices. Update Mega drivers Update Driver Software, Browse my computer... and C:\...\arduino\drivers


If you uploaded a program that uses serial port too often you cannot upload program from arduino IDE. try to press reset button on mega2560 when you begin to upload program. Many times I solved like this.

  1. Check if you have selected the right board
  2. Have you installed FTDI drivers? If you have installed them update them to the latest version. They can be found here (Also see http://arduino.cc/en/Guide/Howto)

If this doesn't work check if the device is getting recognized by the system by running:

dmesg | grep -i tty

If the device is not recognized then try using a different cable/USB port.
Just to make sure, check if the board is working properly by testing it on another computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.