2

I am new to this, and my kid got an Elegoo smart robot car kit v2.0 for Christmas. We assembled the car, but after downloading the software, the program always states:

Arduino: 1.6.13 (Windows Store 1.6.13.0) (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 2,242 bytes (6%) of program storage space. Maximum is 32,256 bytes.

Global variables use 210 bytes (10%) of dynamic memory, leaving 1,838 bytes for local variables. Maximum is 2,048 bytes. avrdude: ser_open(): can't open device "\.\COM1": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

I don't know what other information is important. Can somebody please help me?

Thank you.

2

When the port is greyed out its not available (I know you had worked that out) so you have a problem with you serial to USB drivers.

Looking at the kit I think you are connecting the UNO to a USB port on your PC/laptop using a blue cable.
1. Please can you check that the cable is connected properly. 2. Can you try a different USB port on the PC (don't use a USB hub - some don't work). 3. Does Windows recognise a device has been plugged? 4. Are you running it as administrator, you will need to be to install the drivers. 5. Can you try connecting it to a different PC?

If these don't fix it then, please comment and well go through looking at the device manager.

Hope it works, it looks like fun.

| improve this answer | |
  • Matt, thanks for answering. yes, i've conected the blue USB cable, the device manager sees it as an arduinu Uno. i changed the com port in device manager to com1. (took me a minute to figure out that the com ports were hidden) And yes i an running it as administrator. – Kirk DeVine Jan 9 '17 at 14:50
  • Why did you change the com port in device manager? Normally mine show up as 3, 4 and 22. It's possible you already have something on com1 and this is preventing the ide using it. Also it's worth rebooting, because this can free a com port that has been locked by a process that's crashed. – Code Gorilla Jan 9 '17 at 17:12
  • it was originally 3 and didn't work. i changed it to 1 because that is what the error said it was set on. and since i can't change the port in the arduino IDE, i figured it was worth shot. and i definately tried rebooting as well including rebooting with the uno hooked up. – Kirk DeVine Jan 9 '17 at 19:30
  • Is it an original uno or a clone? Clones can sometimes be awkward. Have you got a spare cable? You might want to try uninstalling the drivers, reboot and then try again (I had to do that for one board). It's possible the cable is dead, the board could be fried (unlikely) or your PC could be being awkward. The setup you have should work, so it sounds like a fault rather than attempting the impossible. – Code Gorilla Jan 9 '17 at 20:03
  • it is an original board i believe. i'm going to try to find another cable. if my computer is identifying the board in device manager then the cable should be working though right? i'll try a new cable tonight. i really do appreciate your time. – Kirk DeVine Jan 10 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.