1

I was wondering if someone could try and solve a major problem I've been having with a brand new Arduino Robot (similar to an Arduino Leonardo). Any input would be very much appreciated!

I've been working with an Arduino Robot on a summer internship for the last week with no major problems. However, a couple of days ago, it stopped running programs and couldn't be detected when being plugged into the computer.

When plugged in or turned on, the LCD turns on with nothing displayed on the screen and the power LED also switches on. However, no program is run (I had a working program involving the LCD uploaded at the time it stopped functioning, which would normally run). Also when plugged in, the Arduino is completely undetected by the computer, with the 'Serial Port' option under Tools grayed out, the device not showing up in device manager, and no signs that a device has been plugged-in. I've tried 3 different USB cables - one of which I tested on another device - and 3 different computers (with Windows 7, 8.1 and Linux Ubuntu installed). On the Linux computer, I ran lsusb before and after plugging in the device and saw no change. I've also tried various solutions such as re-installing the drivers and the Arduino software, using MProg and various rebooting/unplugging-replugging variations.

So I think the problem is almost definitely with the Arduino Robot itself. I'll give a little information about the problems I encountered previously, to see whether something I did affected it or not.

Problem 1:

The first problem I had with the robot was entirely by my own fault and was pretty foolish of me (I'm new to electronics - this being my first project involving it). I ran code from this website (the first set of coding on the page) to try and see whether I could get the LCD to work - not realizing that it wouldn't work for a different type of LCD. After uploading the code, the speaker made a loud constant buzzing noise. Fortunately after uploading a different code, the problem was resolved. I'm doubtful that this could have affected the robot, but since I'm so new to this I'll leave it to one of you to decide.

Problem 2:

The next problem was one to do with uploading. The robot worked fine for a couple of days after the first problem until I came across this one:

When uploading programs, there would be a 'device disconnecting' sound from the computer and the program would fail to upload (I can give details on the error messages if you need them). I managed to solve the issue using an odd solution involving hitting the reset button at just the right time while a program was uploading.

After this, the robot worked for a few hours. In this time I tried to play with the 'turn' function, which didn't seem to work very well at all (the robot would turn angles very different to the ones given) and started creating programs playing around with the LCD. It was at this point the robot stopped functioning properly.

So does anyone have any idea what might be wrong? I have no idea how to fix this problem and I've been trying to find a solution for almost 2 full days now. Any input at all would be greatly appreciated.

  • Have you checked that the power supply is good? When there isn't enough power the mcu will reset and the USB device will disconnect. – Craig Jul 15 '14 at 22:02
2

I'm pretty sure and sadly to announce you that the usb communication of your Arduino Leonardo Compatible is dead and the arduino is connecting to the computer just like an alimentation Source no more. And since Arduino Leonardo based on The ATmega32U4 which has built-in USB communication ,so the Atmedga32U4 is dead(u-processor) too.

It's not a software matter but hardware one.

  • Okay, so is there anything I can do? – jonnolly Jul 15 '14 at 11:58
  • if the arduino doesn't communicate or does not run any program,so the micro-processor is dead,SO no you can't do anything if you don't replace the Atmedga32U4 – Ghayth Mkhinini Jul 15 '14 at 13:46
  • There is a vague possibility that a reflash in DFU mode might fix it; it would at least be worth figuring out what you need to do to put the chip in DFU mode and see if it is recognized as a valid USB device then. – Chris Stratton Feb 13 '15 at 16:49
2

You should try to connect to the board using an in-system-programmer. If you have another Arduino lying around, you can upload the ArduinoISP sketch to and use it as a programmer. Alternatively you can buy a cheap programmer on ebay for a few dollars, just search for "avr programmer". You should look up the placement of the MOSI, MISO,SCK, and RESET pins on your board and connect them appropriately(GND connection is also needed and VCC unless you have another power source).

For ArduinoISP you can run avrdude like this:

avrdude -c avrisp -p atmega32u4 -b 19200 -P [serial port, eg. /dev/ttyUSB0 in Linux]

If avrdude can read the chip signature, then at least part of the chip is probably OK. Try to upload a sketch. If it works, you should locate the Leonardo bootloader and flash it to the board. See if it brings back the USB connection.

If you don't have any luck with these methods you might want to look into high voltage programming.

  • Reflashing the bootloader would be my suggestion too. There's to little information to definitively say the atmega is bricked. – Gerben Jul 16 '14 at 12:40
1

This incident exactly happened for me just now. I solved it by upload simple sketch and double click on the reset button (the board will be detected for around 8 seconds. once the sketch uploaded successfully, the board should be fixed that time.

0

Try this:

  • Bring up a very simple sketch like blink or bare-minimum.
  • Select the right board and serial port from the tools menu.
  • Then click upload
  • As soon as the IDE says 'Uploading' double tap the reset button on the board that you are programming.
  • Hopefully the sketch should upload.
  • You should then be able to upload any other sketch to the Robot like wheel calibration or line follow.

It works for me (since I had the same problem) for a few days until it stops working again. It's Just a design flaw with the ATMega32u4.

  • No, this will not work for the poster. Please read where in the question they explained that the board is not detected as a USB device at all. No USB device means no serial port to select from the tools menu. – Chris Stratton Feb 13 '15 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.