3

I'm trying to connect my Arduino Uno to an ESP-01 module, but I can't get it to start correctly. All I can get out from the ESP-01 is an "invalid" message when it is enabled. Can anyone please help? Additional information can be found below.

Here's my configuration:

  • Arduino connected to a computer via USB cable (serial connection working)
  • ESP-01 connected to the same UART connection, TX from Arduino is lowered to 3,3V with resistors
  • ESP-01 powered with external battery + capacitor to ensure sufficient current
  • I've tried all different configurations with GPIO0 and GPIO2 connecting them to ground and 3,3V, with and without resistors.
  • I've tried 3 different ESP modules

Here's how things work:

  • Arduino sends back every received UART transmission so that I can monitor the whole thing.
  • I can send messages to Arduino from a terminal on the PC and Arduino responds.
  • I can send messages from Arduino by pressing a button and the messages can be seen on the terminal.
  • When I send AT\r\n from Arduino I can read it on the terminal but nothing happens on the ESP-01.
  • When I send exactly the same message from the terminal, the blue light on ESP flashes but there is no response from the ESP. Arduino sends that message back to terminal of course.
  • When I connect CH_PD to 3,3V the ESP gives a message: Ai-Thinker Technology Co. Ltd. invalid
  • The baud rate is correct (115200) since I can only read that invalid message on this rate
1

Sharing the hardware UART between the terminal and the ESP generally does not work well. You'll be much better off to add a SoftwareSerial port on another pair of pins to talk the the ESP.

  • This is one of the common problem that you have got.... If I am not wrong then you are unable to upload program to the esp.... I have a solution please try that it may work for you...... Start the uploading process and unplug the power and plug the gpio 0 to groung and when you see the green to be complete plug the power and at the same time unplug gpio 0.... It may not work at first try... But keep trying, this method worked for me – Shyam Singla Aug 5 '17 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.