1

I bought some ATtiny boards on ebay but I can't get my computers to see them. When I plug them in I get the USB connected sound then a couple of seconds later it gives the USB unplugged sound.

The power light stays on and the LED blinks, I assume it has the blink sketch already loaded.

I have added the drivers to the IDE but I reckon the problem is before that, something to do with the Win10 PC even seeing it. I have two versions of the board, one with a USB socket and one with a USB plug, neither work. [UPDATE] Should have mentioned that the board doesn't show up as being connected to a port

I've looked around for solutions with no joy, I have tried everything I can think of.

Does anyone have a suggestion on where to start troubleshooting this?

enter image description here

  • 1
    Did you try reloading Micronucleus onto them? – Ignacio Vazquez-Abrams Jan 3 '17 at 6:54
  • 1
    Isn't that normal? The board pretends to have a USB interface for a couple of seconds, and then runs the sketch. – Nick Gammon Jan 3 '17 at 6:56
  • @NickGammon seriously???? I had no idea, I thought it was an error...let me test... – Steve Jan 3 '17 at 6:58
  • @NickGammon ahhh...but the board doesn't show up as a port...forgot to mention that. Other boards show up as COM3 – Steve Jan 3 '17 at 7:01
  • YOU GUYS!!! Between Ignazio and Nick I have solved it. I wasn't using Micronucleus, I started to. I thought that no port meant the IDE wouldn't see it but after compiling, and then plugging in the board when prompted it works. I'll update this as an answer when I can – Steve Jan 3 '17 at 7:26
0

There were a couple of comments that both led to the solution.

For me the most important was Nick's that the board pretends to have a USB interface for a couple of seconds, and then runs the sketch. It stopped me tearing my hair out over why the board didn't show up as a port.

Ignacio suggested using Micronucleus. I did this having installed the Digistump drivers and selecting them.

After compiling I was prompted to plug in the board, voila, it uploaded.

Thanks Stack Exchange!

  • 1
    It's amazing that such a small chip can even simulate USB. There have to be some restrictions on the way it works. Anyway, glad we were able to help. – Nick Gammon Jan 3 '17 at 8:38
  • 1
    @NickGammon: The ATtiny85 actually does better than the ATmega328P with V-USB due to the fact that its internal oscillator can be tuned all the way up to 16.5MHz, which opens up almost all Low-Speed USB capabilities. – Ignacio Vazquez-Abrams Jan 3 '17 at 10:32
  • @IgnacioVazquez-Abrams - yes I suppose, but the Atmega328P can run at 20 MHz. Anyway I was really thinking of squeezing it all into quite a small amount of program memory and RAM. – Nick Gammon Jan 3 '17 at 21:29
  • And THAT @IgnacioVazquez-Abrams is going to be my next question. 512 bytes too big, how to squeeze space. But I will make it a real question :o) – Steve Jan 3 '17 at 22:39
  • I have no such luck. The Micronuleous just sits there waiting. After inserting the device. Still nothing. These boards do run the blinky program so it must have got on there somehow. – Justin Feb 21 '17 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.