0

I bought an Arduino UNO R3 Yesterday. It's a Chinese clone. But it has the Atmega328p and MEGA16U2 both. I've installed the IDE fully. But it can't find the ports. The Tools > Ports option is greyd out, Cannot find The options Named "Ports (COM & LPT)" or "Other Devices" in device manager. Can't upload any sketch to board. I tried this on my both Win7 SP1(32 BIT) & Win10, which are installed in the same pc but in different partitions. I've roamed accross stackexchange but no successful result.

  • Have you tried a different USB cable? – Majenko Jan 1 '17 at 12:13
  • There's no issue with my cable I think. The green & orange both LEDs light up when plugged in. – Abrar Borno Jan 1 '17 at 12:17
  • That only means it's getting power. Some cheap (especially chinese) cables don't have data wires, only power wires. Try another cable. One you know for certain works. – Majenko Jan 1 '17 at 12:18
  • That might be. But the drivers ought to be show themselves in the device manager. Or do they require proper connection? – Abrar Borno Jan 1 '17 at 12:32
  • The drivers don't show, only the device shows. If the device isn't detected there will be nothing there. Windows contains thousands of drivers. If the device manager listed the drivers instead of the detected devices it would be completely unmanageable. – Majenko Jan 1 '17 at 12:33
1

You may not have installed the drivers when installing the IDE. The only way I know to reinstall the drivers is to reinstall the IDE and make sure when you get to this screen you tick every box:

Install Arduino

Otherwise you may not have selected your board correctly. To select your board in the IDE, go to Tools > Board > Arduino Uno/Genuino Uno

Your port select may then appear, it should be COM1 or something similar. If you have multiple, just try them all by selecting one and then upload a sketch to it. The Arduino Uno should flash some lights if it worked correctly.

Board

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.