2

I just got a new pro-micro Atmega32U4 board, and installed the current Arduino IDE (1.8) and cannot get it working.

There is no entry for a pro-micro, so I chose Leonardo as it uses the same chip.

When I choose upload, the two red LEDs blink fast, but I get an error from avrdude, saying that it cannot upload the code.

The board is probably from a Chinese web shop ($6 clone). There are no buttons on the board.

My questions are:

  • Is there already a bootloader on the chip, or do I have to program one? How do I check this?

  • How does it know that it must receive an upload, instead of running the flash program?

  • Which board should I choose in the IDE?

This is the error:

Couldn't find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board's reset button after initiating the upload.

It looks exactly like this one.

Update: I did everything the manual said. I can choose the pro-micro now. Still the same error message. How do I check what state the bootloader is in?

3

There is an extensive guide written by SparkFun explaining how to work with Arduino Pro Micro: Pro Micro & Fio V3 Hookup Guide.

There are specific drivers for the board, so make sure you have them installed. There are also board files for the IDE, which allow you to select the Pro Micro in Arduino software.

0

I'm answering my own question. It works now. You must reset it (maybe twice) before you can upload software to it. I soldered a few wires to it for this. That did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.