1

I have Ubuntu 14.04 installed on a chromebook through crouton. I'm trying to install the Arduino IDE. I figured out that I needed the 64-bit version of the IDE and downloaded it. Then, I started following the instructions given - I found the downloaded file, which was named arduino-1.8.0-linux64.tar.xz, opened it (this opened a new window in a program called Xarchiver, which listed the subfolders and files), and saw the install.sh file. When I right-clicked, there was no option to run it from the terminal, so I went back to the terminal and did cd Downloads and then tried to cd into the downloaded file. However, it said that there was no such directory. I listed the files in Downloads, and the downloaded file came up, listed in red.

How can I run the install.sh file? What am I doing wrong? Any help would be appreciated.

2

You need to extract the archive file first.

$ cd ~/Downloads
$ tar -Jxvf arduino-1.8.0-linux64.tar.xz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.