2

I am using Linux Fedora 20 (yes I am going to upgrade it, definitely, soon) and I have installed arduino-1.8.0, but I get this message ...

Your copy of the IDE is installed in a subfolder of your sketchbook. Please move the IDE to another folder

... when I click on the desktop icon, or run ./arduino. I have tried moving the tar.xz file to its own folder ArduinIDE again installed it but get the same message. Please,what should I do to get out of this? Please no answers like "just do what it says":in that case what do I move, and what criteria does the destination need to have?

4

Delete (or edit) your preferences.txt file - it most likely has your sketchbook folder set to your home directory.

You may find it in ~/.arduino15 for the "real" Arduino IDE, or in (I think) ~/.arduino for the arduino.org one.

Unless you have a specific reason for wanting to run 1.8.0, which is actually 1.0.6 re-numbered, you should be using the version from arduino.cc which is currently 1.6.13.

| improve this answer | |
  • Thank you Majenko. I uninstalled 1.8.0 and installed 1.6.13 instead, then the problem was cured when I altered the line in my home directory /home/Harry/arduino15 from sketchbook.path=/home/Harry/ to sketchbook.path=/home/Harry/Sketchbook – Harry Weston Dec 23 '16 at 17:31
  • "1.8.0, which is actually 1.0.6 re-numbered" This is incorrect. You're thinking of the arduino.org 1.7.x releases. The 1.8.x releases started after the legal dispute was resolved and .org started using the .cc IDE again. They jumped straight from 1..6.13 to 1.8.0 to avoid any confusion with those 1.7.x releases. 1.8.0 was released Dec. 20 '16. – per1234 Sep 13 '17 at 21:06
  • This fixed it for me. Funny thing is that in my case I have Arduino IDE run inside a VM (VirtualBox), which crashed (I had to restart the host due to some reason). Before the crash I didn't have a problem but after that I did. Note that in my case the sketches were in a completely different folder: /home/user/ArduinoProjects, while the IDE was in /home/user/Arduino. – rbaleksandar Nov 11 '19 at 19:25
0

This is still happening. The exception message is not clear. It is objecting to being installed in "the same folder as your sketchbook", not in a "subfolder of the sketchbook". It should ideally read...

Your copy of the IDE is installed in the parent folder of your sketchbook. Please move the IDE to another folder.

You should be able to put side by side versions in /opt or create another branch in your home folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.