I have an arduino duemilanove with ATmega328.

Been doing several experiments with multiple peripherals

I had no problem uploading at all

But when i try to upload a big program (27,074 bytes (of a 30,720 byte maximum)) it compiles fine, then says uploading...

After some time passes i get this error

avrdude: stk500_getsync(): not in sync: resp=0x00

The board and serial port connections are fine. Any ideas?

PS: Then i tried to upload the blink example, but i get the same error for some reason Everything worked fine before i uploaded my "big" program


The sync error is a common issue that doesn't have one simple solution (as shown here)

It means that the computer can't communicate with the processor, but it recognizes that it's there (out of sync). This is probably due to something (a peripheral, stray wire) interfering with the transmission from computer to device.

Solutions that have worked in the past:

  • Unplugging the Arduino for 30 seconds, then plugging it back in.
  • Removing any wires connected to Rx and Tx pins during upload.
  • Soldering components connected to Rx or Tx to the board (in this case, I was using a shield that allowed me to do this)

There are lots of solutions available from different sources on the internet, but I have not come across one that names program size as the reason.

  • Removing any wires connected to Rx and Tx pins during upload. This was the issue after all. Thanks! Jul 31 '14 at 20:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.