0

When I plug my new UNO R3 board into a PC's USB port it powers on but no device is detected by the operating system. I've tried on three different PCs, Windows 7, 8 and 8.1 with multiple different cables. My guess is that the board is defective but would appreciate any pointers you can give.

  • 1
    Welcome to Arduino SE! Have you installed drivers? Anything connected? – Anonymous Penguin Jul 9 '14 at 22:00
  • 1
    Does anything show in the device manager, like a yellow-questionmark? Do any of the leds on the arduino board light up? Most likely it's just defective, and you should return it. – Gerben Jul 10 '14 at 13:55
  • 4
    I'm voting to close this old abandoned question as it has never had any specifics which would make it answerable or differentiate it from the many other questions stating a similar problem here. – Chris Stratton May 5 '18 at 15:09
  • Agreed, as there are too many similiar ones, I've also checked the answers, of which the only relevant one you also argued. If people search on google for "Arduino board not detected" I rather have them find a more relevant source. – Paul May 5 '18 at 22:02
1

It shouldn't be detected by Windows. You must install the software for your operating system here. Scroll down to Arduino 1.0.5 and click on windows. after installing, open up the Arduino IDE (it should be labeled "Arduino" on the desktop or start menu/screen). Plug in your board, and go to Tools> Serial Port. Select COM3. If it is grayed out, it has been auto-selected for you. The reason it won't work without the software is that the UNO and other Arduino boards don't have "true" USB. They basically emulate a serial port over an usb connection.

  • This is incorrect. Windows should detect that there is a device there, and start working with you to find a driver for it. Even just a pullup resistor from one of the USB data lines to VBUS would prompt this behavior. If that does not happen, either there is already an installed driver, or the board is dead and not pulling up one of the data lines to be recognized as present by the computer. Also, they very much do have "true" USB - the service that they offer over it is a USB serial port. – Chris Stratton May 5 '18 at 15:12
0

I couldn't bypass com1 port in arduino 1.0.6. So I wired the arduino to a sparkfun on the anolog in: A0,A1, A2, A3, A4, and A5 via a microusb cable to the computer. Lay the sparkfun on it's face so the back is upward. Put a wire in the left pin and connect it to A5. The next to A4 and so on. Try the blink test. It prompted me to change my port because com1 was not available. So I changed to com3 and tried again. Now disconnect the sparfun and connect to the arduino directly via the printer port. Try the blink test. It prompted me to change my port because com3 was now unavailable so I chose com4. Try the blink test again. It should work.

  • Welcome to Arduino SE! Can you please explain how this works? What Sparkfun board are you talking about? Thanks! – Anonymous Penguin Oct 19 '14 at 22:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.