I've recently made a custom library. Then, I've imported the library into the IDE via the add .zip library. Once I tried to compile the code, I've realised that I made a small typo. Once I changed the error and then retried to compile the code, the error still appeirs and I'm quite sure that I've changed it.

So my guess is that the library is not updating. I've tried to go to manage library and then seeing if there is an other version of the library. There wasn't any.

So is there an easy fix to this solution that doesn't involve updating or downgrading the IDE?

  • I've never used that option but normally you just need to delete the compiled files in the library. So assuming they aren't in the zip file, are they somewhere in you profile's temp directory? – Code Gorilla Dec 6 '16 at 12:54

Text from here says this:

In Arduino v16 and earlier, libraries were stored in the ArduinoInstallDirectory/hardware/libraries folder, which also contained all the built-in libraries (like Wire and Serial).

In v17 and up, the user libraries are now stored in the ArduinoSketchDirectory/libraries folder.

Check your version of the Arduino SDK and then look in the appropriate directory for your library source code. Then change it there.

The Arduino SDK is fairly simple and often compiles everything to avoid problems like this. The installing from a zip file feature (unless it has changed) is more for convenience when downloading a single zip file. I have often developed & edited custom library source code where the SDK expects to find it.

  • Thanks, but I'm using the IDE from Arduino.cc and not the one from Arduino.org. – Dat Ha Dec 6 '16 at 14:16
  • If you could elaborate what difference that would make I would appreciate it. I would learn something and possibly make the answer better. – st2000 Dec 6 '16 at 14:26
  • Also, you might check the time stamp on your source files to make sure they are newer than the compiled files. – st2000 Dec 6 '16 at 14:27
  • I there is no real difference except that the .org version is all orange compared to the more user friendly .cc. No real diferrences. 1.7 is the latest of .org. I believe and it hasn't changed much. .cc` on the other hand has regular IDE updates. Heck, one just got released around 2 weeks ago. Its IDE version 1.6.13. – Dat Ha Dec 6 '16 at 15:09

I actually found this answer on Stack Overflow.

In the Arduino GUI on windows, if I click on Sketch --> Import Library, at the bottom of the menu there is a section called "Contributed".

Unfortunately, I had misclicked and added a library I did not want to that list.

How can I remove it from that list?

The help page only mentions that "If a sketch no longer needs a library, simply delete its #include statements from the top of your code" but it does not mention how to remove the library from the list of contributed libraries.

By : @merlin2011 from Stack Overflow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.