3

So, before starting to learn with something else, I'll give it one last try. The avrdude is complaining that the device signature doesn't match. Whatever, I don't care. To me, what's written on it is what counts.

So I'd like to force it to upload the program. It promises to ignore the problem if -F is specified.

Where are settings for avrdude parameters, like other IDEs have settings for their compilers?

  • 3
    Have you determined that avrdude works with -F outside the IDE yet? – Ignacio Vazquez-Abrams Jul 2 '14 at 0:30
  • Are you sure you have the correct board type set up and are trying to connect to the correct board? – jippie Jul 2 '14 at 5:35
  • In the verbose output of the message window at the bottom of the IDE, you could copy and paste the avrdude command line and add the option yourself. I've never manually compiled or tried it this way, give it a go and see if it works – Madivad Jul 2 '14 at 13:51
  • Well, I also don't seem to able to find where is the temporary folder for compiled code. And as of are you sure question - I'm not sure about anything. And avrdude is not helping me to be sure with it's unhelpful errors. – Tomáš Zato - Reinstate Monica Jul 2 '14 at 18:13
  • If you have an incorrect device signature, using -F won't fix anything, since it'll be trying to program the wrong microprocessor. What is the actual device signature avrdude is reporting? – Connor Wolf Jul 3 '14 at 22:44
3

The error probably means that you have selected a wrong configuration.

To modify the IDE to insert the -F seems to be the hard way, however the easy way is to make a wrapper to avrdude:

$ cd ./arduino/hardware/tools/
$ mv avrdude avrdude.orig
$ cat >avrdude.sh
  #!/bin/sh

  ./avrdude.orig -F $@
  ^D
$ chmod +x avrdude.sh
$ ln -s avrdude.sh avrdude

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.