2

I am powering my Pro Mini(3.3V version) using an external battery (~6.5V 700mA) . I used to connect it to the RAW and GND pins on my pro mini and everything ran fine.

Today when I powered up my Arduino again, it didn't light up. A quick glance told me that I had connected the battery to the RST and GND pins mistakenly. Quickly pulled them out and put them into place, the Arduino worked perfectly until I discovered that the RESET button is no longer working. Without the RESET button I can't upload anything to my board.

Tried connecting the RST and GND Pins, didn't work.

The board is working fine though, I discovered a new procedure to upload as follows-
NOTE: I use the USB-to-TTL adapter by DSUN (picked up at a local electronics store).

  1. Connect the RX, TX and GND Pins from the adapter to the Pro Mini.
    (The green LED on the Pro Mini lights up dimly)
  2. Upload the sketch from the IDE.
  3. As soon as the IDE shows "Uploading", connect the +5V pin from the adapter to RAW pin on Pro Mini. Upload goes fine.

The above procedure is working just fine, and the board as well. But I'd like to have my RESET button back.
So what do I do?

  • You could probably still use that Arduino in a final project where compilation will only happen once, other wise RIP. – Dat Ha Nov 12 '16 at 13:12
  • 1
    You can buy a Arduino Pro Mini for $2 or less, so I guess it not worth using-It's dead Jim. "Do not grieve, Admiral. It was logical." – Dat Han Bag Nov 12 '16 at 17:31
1

What do you do? You replace the chip on the board.

By pumping 6.5V through the RESET pin with no power attached you have irrevocably broken the reset pin inside the chip. Way too much current will have flowed through the internals of the pin leaking its way up to the VCC pin and then back down through the rest of the chip to ground, burning out vital parts of the internal logic of the pin.

It's dead, Jim.

Your "fix" basically relies on the fact that the bootloader runs for any kind of reset - be that a RESET pin reset or a POR (Power-On Reset).

  • Hmmm so my fix can still get the board running anyways right? – YaddyVirus Nov 12 '16 at 13:59
  • Yep. As long as there is a power-up event (even a brief drop-out of power would do) the bootloader will run. – Majenko Nov 12 '16 at 13:59
  • As if holding the RESET button while uploading wasn't annoying enough. Anyways thanks! – YaddyVirus Nov 12 '16 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.