1

I am using circuits.io with Arduino. my program is to blink the led with 2 seconds delay. The led in the circuit blink according to program but the bulb does not blink. I am very weak in electronics. This is what i starting to learn from the scratch. the problem here is the bulb doesnt blink according to the program. which is meant to blink. i have uploaded the circuit image below.. . thanks in advanced.

Please check the Image here

  • 3
    Your layout makes no sense. Please post a schematic showing all the circuit connections and the power input to the arduino. – EM Fields Nov 5 '16 at 11:06
  • 1
    you show no ground connection between arduino and relay, does this represent what you have? – Neil_UK Nov 5 '16 at 11:33
  • 2
    this layout... use the schematic editor. – Bradman175 Nov 5 '16 at 12:04
  • 1
    In the circuit.io layouts that I have seen, they do connect power to the Arduino board. You have yet to do this. (There are other problems, but let's start with the obvious one 1st.) – st2000 Nov 5 '16 at 14:02
  • 1
    Sorry, I downvoted this, because even after three hours of being pointed to a lack of clear schematic, you haven't tried to improve your diagram. Thus, no answer can be given, and your question holds no value in itself. – Marcus Müller Nov 5 '16 at 14:28
1

If you wire up your circuit as shown below, the bulb and the LED should flash together.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.