I have been working merrily along with CH340 to make Com10 work. It has been working flawlessly but now I am getting various messages like it can't open the port then the programmer is not responding. It tries several times before giving up.

This was working fine yesterday.

I tried uploading to a raw board not connecting to anything and am getting the same result.


  • Throw away the CH340 and use something that is more likely to last you more than a few days.
    – Majenko
    Nov 6 '16 at 12:05
  • I believe CH340 is installed with the IDE. I did a reinstall and it still shows it. I have used it for several months just like this. But I do see your point - since the same problem happens with multiple boards the problem must be in the PC.
    – SDsolar
    Nov 7 '16 at 3:52

This problem occurs quite often with all the boards. Here is how to troubleshoot it.

1 - Unplug the Arduino.

2 - Upload the program WITHOUT any boards connected to your computer.

3 - Replug your Arduino.

4 - Upload the program WITH your Arduino connected to your PC.

If this doesn't work, read this post by Nick Gammon.

  • @ Dat Hair Do.----in additon to above answer- you may connect the arduino on another computer running arduino IDE if that possible. If the arduino is detected and works on another different PC than it still ok. That may save time - if you have multiple PCs or can borrow one-if you just want to know your arduino still works. Nov 6 '16 at 0:17
  • @ Dat Hair Do ---the idea in the above comment has now been added by Nick Gammon to his post. So its a good idea. I would give try the stuff with it if possible Nov 6 '16 at 14:08
  • @yabbadabba, why the hell do you call me Dat Hair Do? Please stop or I'll be forced to flag you.
    – Dat Ha
    Nov 6 '16 at 14:41
  • @yabbadabba - Please read the Be Nice policy
    – Nick Gammon
    Nov 7 '16 at 20:53
  • I found a method that works and added it as an answer. I am glad that it is acceptable to post answers to our own questions as we learn more. My desire is that this might be useful to others.
    – SDsolar
    Nov 8 '16 at 4:51

OK, problem solved. I wish I knew enough to be able to say why it worked, but here is what did the trick:

I uninstalled the IDE.
Then installed the IDE (version 1.6.10) again, this time not selecting the USB driver.

In Device manager it still shows the CH340 driver on COM14

All my sketches and the two libraries (DHT and LCD) in the documents/Arduino directory were unaffected.

And now it will upload to my boards just fine.

This is one of those times where I can't explain why, but I can tell you for sure that it worked for me. I had tried uninstalling/reinstalling, but without the rebooting in between. Perhaps that was the crucial step that needed to be taken.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.