1

I am using a Pro Mini and the Arduino Eclipse plugin. I have a project that is close to 1,000 lines of code and I am using things such as analogRead() and the u8g display library. Now I am at the point where I want to save data to EEPROM but I can't, because it says "eeprom.h (no such file or directory)". I have tried including this library in both my main file (where the setup and loop functions are) and also in my own .h files, which are in the same folder as the main file. Any thoughts on this?

  • 3
    Arduino library is <EEPROM.h> and avr library is <avr/eeprom.h>. It depends, which one do you want. – KIIV Oct 11 '16 at 12:35
1

I'm sorry but it's quite difficult to understand what you are asking. Are you saying you are trying to write some code to write to an EEPROM and you can't find eeprom.h?

1,000 lines isn't a big enough program to cause issues unless there is a problem with your IDE. This file should be included from you main file. If you were using the Arduino IDE then there is a feature to include the library and it adds the #include statement for you.

I don't know what operating system you are using, you didn't say but have you searched for the file? Does it exist? Have you got the correct case for the filename (doesn't matter on Windows)? I think it is called EEPROM.h, maybe changing the name in the include statement will help.

What can't find the file, Eclipse or the compiler? If it's your IDE it shouldn't matter.

Have you got an EEPROM library and can you build and run the examples?

I don't know if this version of Eclipse and the plugin is recent or not, it's possible that the EEPROM library is not supported on this version. You would need to research that. When you encounter problems with third-party tools, it is usually best to revert to the Arduino IDE and check that the tool is functioning correctly.

  • I am saying I can include Arduino.h and use it with no problem, I assumed eeprom is same , meaning no need to download anything once the eclipse manager finished downloading the board. – nhrnjic6 Oct 11 '16 at 16:53
  • I solved it, platform libraries are not included by default, so I just had to check it. Thanks for help anyways. – nhrnjic6 Oct 11 '16 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.