0

I was working with Arduino in Win 8.1, when suddenly it stopped work. I tried to reinstall the drivers and IDE several times, but it didn't solved.

In Win 8.1, when I plug the arduino, I get the pop up message:

USB Device Not Recognized in Windows

Also, when I try to upload a sketch, I get this error in Arduino IDE:

avrdude: ser_open(): can't open device "\\.\com5": the system cannot find the file specified

I switched to Linux (Debian Jessie 64 bits), but it also doesn't get recognized, and I getting the same error, only the port Is different.

I am guessing is a problem with avr, but I don't know what can I do about it.

Other symptoms:

  • In both systems the port tool in IDE is grey, so I can't choose a port.

  • When I press the reset button in Arduino, nothing happens.

  • The led L (13) is constantly shinning. It never blinks or stops.

Solutions I tried:

  • Reinstall drivers
  • Modify the preferences.txt file to change the COM port
  • Fall back to a previous IDE version
  • Change the usb cable

migrated from electronics.stackexchange.com Oct 9 '16 at 20:21

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

1

If the port selector in the IDE is greyed out, and the OS is throwing an error, it's likely the Board is damaged. Either The firmware on the serial device or the chip is fried somehow. What's happening is that the usb part is failing, so the Com port part never works.

  • By chip you mean the atmega? – EGS Oct 9 '16 at 14:51
  • The FTDI or USB Atmega in charge of the usb to serial. If it's atmega based, then it's possibly you tried to program that one and everything messed up at that point. – cde Oct 9 '16 at 15:14
  • Yeah... It seems right. – EGS Oct 9 '16 at 15:18
0

Arduino is most probably aproaching the wrong com. You can set a new com. in the IDE of arduino under settings. Change it to the available com. It might be required to find out in Windows/ system configuration for the available coms Maybe something there is wrong.

  • I am not sure, where I would set the new COM. The port tool is grey. Are you talking about this? – EGS Oct 9 '16 at 14:25
  • I can not help with the Windows details because I have a Dutch version Windows 8 operational – Decapod Oct 9 '16 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.