0

When I upload my sketch I get this error message:

avrdude: ser_open(): can't open device "\.\com3": the system cannot find the file specified

I tried reinstalling the IDE and the drivers. I tried looking into the preferences txt file and the COM was alright.

Also, I uploaded it successfully from another computer.

What is wrong about my PC trying to upload Arduino? And the most curious thing of all is that yesterday it was fine and it was working.

closed as unclear what you're asking by Chris Stratton, Mattia, KIIV, Dat Ha, sa_leinad Oct 20 '16 at 14:22

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you tell your file name? Maybe it contains bad symbols? – Mae Oct 9 '16 at 17:52
  • @NewDevelop - the "file specified" refers to the serial port, which is a file-like object. – Chris Stratton Oct 9 '16 at 19:02
  • It would be easier to answer your question if you also posted the full command line used by Arduino IDE to launch avrdude. Note that "\.\com3" looks weird, shouldn't it just be "com3"? – jfpoilpret Oct 9 '16 at 20:55
1

First of all DON'T PANIC, it's more than probable your Arduino is not broken. Start running the following checks:

  1. is any other software using the same serial port? serial ports cannot be concurrently opened by multiple processes...
  2. disconnect the board, reset your PC, wait until the boot process is completed and then connect again: does your OS recognize the COM port? (Windows emits a sound, GNU/Linux logs a few lines...)
  3. check the COM port matches, may be your board is no more recognized as COM3 but as COM4, depending on multiple factors
  4. if you have anything wired to your board, disconnect everything, unplug the board and then re-connect the board alone, with nothing connected to its pins: you might have a short somewhere or using pins 0 or 1 (marked as RX & TX, they are also used for communication)
  5. is your USB cable connection flaking? it might seem stupid, but if you have multiple cables running around your PC it is indeed possible to pick the wrong one or loose it from the socket...
  6. are you using a cheap cinese clone? There are clones using counterfeited USB chips which get banned by Windows automatic updates, but a workaround exists even for that

While it is possible to brick the Arduino boards via software, there are very little possibilities you did it because it involves using tools completely hidden to the Arduino occasional user / newcomer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.