0

I am running a linux distro on my pc(Ubuntu 16.04). I have installed Arduino IDE(version 1.0.5 since it's the only one available on the store) from the Ubuntu Software Center and also using the .ZIP file from the official Arduino website(version 1.6.11). When I ran IDE(1.0.5) the "Serial Port" drop-down was greyed out. Next ran the IDE(1.6.11) and again the "Port" drop-down under Tools was greyed out. I have spent hours looking online for a solution but all in vain. A tried and tested working solution will be highly appreciated.

  • Are you in dialout group? – KIIV Sep 6 '16 at 6:50
  • Well, every time I launch the IDE it shows me the following message: You need to be added to the "dialout" group to upload code to an Arduino microcontroller over the USB or serial ports. Click "Add" below to be added. You must log out and log in again before any group changes take effect. And then as instructed I clicked on the add button. Even then the Serial port remained greyed out. And besides, shouldn't the adding be a one time thing? Why do I have to do it every time I launch the IDE? – ShuaibKunji Sep 6 '16 at 9:27
  • Maybe you don't have enough access rights to change it. Otherwise it should be one time action. Try to add this group for your account from root account (or with sudo). – KIIV Sep 6 '16 at 9:43
  • Or launch the IDE from the root account and let it sort it out for you. – Code Gorilla Sep 6 '16 at 10:38
1

Information on a “Serial Port Setup” page at fedorahosted.org should be adequate to sort the problem manually. Here are a few snippets from that page, along with notes about application to the current problem.

• Use command ls -l /dev/ttyUSB* to find out the serial port's group. For example, on my Ubuntu system that shows

crw-rw---- 1 root dialout 188, 0 Aug 20 11:13 /dev/ttyUSB0

Note, substitute for ttyUSB if the port you're concerned about doesn't start with that.

• Use command groups to find out which groups you belong to.

• The fedorahosted page says to use command sudo adduser (username) dialout to add dialout to your groups list. I haven't tried that approach, and would be more inclined to instead try sudo usermod -a -G dialout (username) [where “(username)” represents your username].

  • One must then log out and log back in for the group membership change to take effect. – Chris Stratton Sep 26 '17 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.