1

I'm working on Linux Mint 18 Sarah (earlier Ubuntu 16.04 LTS) system. I've installed Arduino IDE using command sudo apt-get install arduino and I've added me dialout group using sudo usermod -aG dialout $(whoami). This is results of executing groups command:

hubert@hubert-SATELLITE-C660D ~ $ groups
dialout adm cdrom sudo dip plugdev lpadmin sambashare hubert

When I try upload following code to Arduino Leonardo:

/*
  Blink
  Turns on an LED on for one second, then off for one second, repeatedly.

  This example code is in the public domain.
 */

// Pin 13 has an LED connected on most Arduino boards.
// give it a name:
int led = 13;

// the setup routine runs once when you press reset:
void setup() {                
  // initialize the digital pin as an output.
  pinMode(led, OUTPUT);     
}

// the loop routine runs over and over again forever:
void loop() {
  digitalWrite(led, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(500);               // wait for a second
  digitalWrite(led, LOW);    // turn the LED off by making the voltage LOW
  delay(500);               // wait for a second
}

orange LED marked with L letter on my board blinks and next I get following error:

Wielkość binarna szkicu: 4 736 bajtów (maksymalnie: 28 672 bajtów)
processing.app.debug.RunnerException: Couldn’t find a Leonardo on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.
    at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:153)
    at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)
    at processing.app.Sketch.upload(Sketch.java:1671)
    at processing.app.Sketch.exportApplet(Sketch.java:1627)
    at processing.app.Sketch.exportApplet(Sketch.java:1599)
    at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380)
    at java.lang.Thread.run(Thread.java:745)

On my IDE Arduino shows on /dev/ttyACM0 serial port. When I try running this IDE on root privileges, I get the same error. On root privileges serial port is changing from /dev/ttyACM0 to /dev/ttyACM1, from /dev/ttyACM1 to /dev/ttyACM2 etc. I tried different USB cabels and reset Arduino but these ways nothing help. On Windows 7 my Arduino works and Arduino IDE uploads code without problems. Can anybody help me?

  • Read this: hackingmajenkoblog.wordpress.com/2016/08/24/… – Majenko Aug 27 '16 at 13:25
  • FWIW my money is on ModemManager. – Majenko Aug 27 '16 at 13:43
  • Are you create ModemManager app? – hubot Aug 27 '16 at 13:47
  • No. "my money is on..." is a British idiom meaning "If I were a gambling man and I placed a bet on the cause, I would bet on it being ModemManager". – Majenko Aug 27 '16 at 13:48
  • What exactly is ModemManager? – hubot Aug 27 '16 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.