0

avrdude:

no programmer has been specified on the command line or the config file Specify a programmer using the -c option and try again

2 Answers 2

1

On the "Tools" menu choose "Programmer:" and specify AVRISP mkII; be sure that you've also chosen the appropriate "Board:" entry for the Uno. enter image description here

3
  • yeah i know all that but it keeps showing me the same error!!! Commented Aug 25, 2016 at 20:56
  • Describe your environment: Windows? Unix, which one? Which version of the Arduino IDE? Or, are you using Eclipse or another IDE? Perhaps you need to re-install? Has it ever worked? Does, "Get Board Info" work? Commented Aug 27, 2016 at 1:11
  • Oh, are you trying to use the command line tool (avrdude?) Commented Aug 27, 2016 at 1:21
-1

I fixed it. I just reinstalled the drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.