2

I am running Ubuntu Mate 16.04 LTS, with an Arduino Uno R3 clone. I am having the dreaded serial port graying out problem, and have not found a solution for fixing it. Currently, The serial port will grey out sometimes, and sometimes it will be not grayed out, and I can see that I have selected ttyUSB0. Usually when it is not grayed out, uploading a sketch will not work, and I get the error like it is grayed out:

avrdude: ser_open(): can't open device "/dev/ttyUSB0": No such file or directory An error occurred while uploading the sketch

chmod a+rw /dev/ttyUSB0

doesn't solve the issue, with log out included

gpasswd -a aaron dialout

doesn't solve the issue, with log out included

I searched preferences.txt and serial.debug rate is set to 9600

I have tried entering preferences.txt and deleting all of the serial entries. They are recreated the same after deletion, and this doesn't solve anything.

I tried running as sudo, doesn't work.

I tried solving this originally on Arduino IDE 1.0, didn't work.

I have upgraded to Arduino IDE 1.6.10, still not working.

running lsusb in terminal yields this while Arduino is plugged in:

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Checking var/log/syslog after plugging in Arduino:

kernel: [42043.787178] usb 3-2: new full-speed USB device number 109 using xhci_hcd

kernel: [42043.916241] usb 3-2: New USB device found, idVendor=1a86, idProduct=7523

kernel: [42043.916249] usb 3-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0

kernel: [42043.916253] usb 3-2: Product: USB2.0-Serial

kernel: [42043.916964] ch341 3-2:1.0: ch341-uart converter detected

kernel: [42043.918199] usb 3-2: ch341-uart converter now attached to ttyUSB0

mtp-probe: checking bus 3, device 109: "/sys/devices/pci0000:00/0000:00:14.0 /usb3/3-2"

mtp-probe: bus: 3, device: 109 was not an MTP device

Ran to add to dialout group, then logged out

sudo usermod -a -G dialout aaron

No solution. So it looks like Arduino board is not being recognized. Not sure what to try next. It is important that I have uploaded sketches before, but am not sure if there is a pattern to when it does not work. It does not work 95% of the time.

Thanks for the help!

  • 2
    How's about showing us what gets logged in /var/log/syslog when you plug in the arduino usb cable. – st2000 Aug 8 '16 at 4:39
  • The magic word in your question is "clone". You're very much on your own unless you can identify just what components are in use on your board, especially the USB interface chip. The smart money is on it being a CH340 chip, and those are notoriously unstable and break very easily. – Majenko Aug 8 '16 at 9:17
  • They break under Windows, not Linux. Is your user in the dialout group, Aaron? You must be to use serial ports. – Avamander Aug 8 '16 at 9:46
  • 1
    @Avamander They break in two ways - one is shoddy drivers in windows, the other is a complete disregard for any form of ESD protection. They die horribly and never work again. – Majenko Aug 8 '16 at 16:02
0

I have the same problem, I believe that the problem is related to the 4.x kernel, since I have already tried another distribution with the kernel mermo and the problem persists. Using a windows virtual machine as guest works, which excludes communications and hardware issues.

  • 2
    Hi Ronaldo and welcome to SE Arduino. While your answer is good, and maybe correct, do you happen to have tried another version of the kernel (which is not 4.x) that works? I only ask, as it would help to back up your claim. Also, any links to documented evidence that also backs up your claim would be great. In addition, what is "kernel mermo"? I can find no reference to it on the web. – Greenonline Feb 4 '17 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.