0

I have ESP8266 WiFi module and Arduino Mega Board connected. I use external 5 to 3.3 V regulator to power up the module. Common (-ve) line on the external power source and Arduino Mega GND is connected. Then I used 1K and 2K voltage divider for WiFi module RX and TX use as same. I am sure my circuit is well works.

Then I connect RX0-RX and TX0-TX. Then i put CH-PD to 3.3v

Then I opened the Arduino IDE and upload the Blink sketch. Done.. Then I opened Serial Monitor and set baud rate to 115200. Then power up the module. It gave me a lots of garbage values and ready. Fine.

Then I downloaded the FLASH_DOWNLOAD_TOOLS_v0.9.5. configure the 0x0000, 0x1000 and 0x7c000

  1. SPI speed = 40MHZ
  2. SPI mode = QIO
  3. FLASH size = 4Mbit
  4. 0x1000 = ai-thinker-0.9.5.2-9600.bin

Then O power off the module and connect GPIO0 to ground and again power on.

Then push start button. Then it downloaded to the chip. It worked. Done. Success fully uploaded. Then I again disconnected the GPIO0 and power on. Then I put AT and it results OK.

AT+GMR gives version 0.9.5 updated.done.

The problem was the module was responded for 115200 baud rate, not 9600. Then I:

AT+IPR=9600

it gives me nothing.

Now I can't communicate with it at either 115200 or 9600 baud. No respond whatever baud rate I put. Sometimes I am having same garbage values.

  • The command to change baud rate is AT+UART_DEF. Have you tried re-flashing the module? – TisteAndii Aug 4 '16 at 16:39
1

This is a common issue. Using the AT+IPR command seems to brick the module. Try to re-flash your module, like you did the first time. If it works, use this command: AT+UART_DEF=9600,8,1,0,0 instead to change the baud rate.

  • Thank you reply me. I tried to reflash it. use baudrate 115200 .then the blue Led is blinking. after a little time blue LED went off. the software shows me to IDLE mode to Download mode but prograss bar doesn't update.it is stucked. – Kolitha Warnakulasooriya Aug 5 '16 at 3:25
  • @KolithaWarnakulasooriya The flashing completed successfully? Have you tried sending AT? – TisteAndii Aug 5 '16 at 3:28
  • No it didnt uploaded to the chip.software didnt show the success message.yes i tried to send AT. I set the end charachter type as Both NL & CR. baud rate 115200 ; nothing. – Kolitha Warnakulasooriya Aug 5 '16 at 3:34
  • when i power up the module it gives me garbage values – Kolitha Warnakulasooriya Aug 5 '16 at 3:39
  • Note:Serial port connected. Note:Begin find ESP8266. Note:ESP8266 ACK success. Error:Read ESP8266 register timeout. – Kolitha Warnakulasooriya Aug 5 '16 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.