0

I have a Nano (clone) that I am powering from a regulated supply via the 5V pin; I have checked this at the board and my multimeter reads 4.92V, which seems close enough (?). The main reason I don't use the microUSB jack is a space constraint. In any case, thus far it does work fine.

Except the leftmost (considered with the microUSB jack as "top") of the four onboard LEDs, on the opposite side from the rx/tx lights, blinks at a steady one second interval. Searching around, the only association I've found for that LED is that it is connected to D13, which I'm not using for anything.

What does this indicate? I have not tried disabling it (by setting 13 low) but I am hoping to do so if it is a benign issue.

2
  • Do you have the Blink sketch loaded by any chance? – Majenko Aug 2 '16 at 16:31
  • @Majenko No, I've never used that. To double check it wasn't something I'd done though, I took it out to reflash it and noticed it did the same thing w/ the USB power :\ When I reflashed it it stopped, and it doesn't do it anymore via the 5V pin either. I just assembled this one, and D13 is attached, but the only thing it might conceivably have been used for would be driving a servo or reset. Since there was a pin connected to reset, I tried that driven low instead of high and guess what? – goldilocks Aug 2 '16 at 17:55
1

So, as per the comments on the question here's what I think happened:

That "test" LED lights briefly when the board is first powered on, indicating I suppose that it's booted and setup() is either complete or about to run.

It also lights briefly when the reset button is released.

In the sketch I'm using one of the digital pins is connected to RST -- the arduino is being controlled via UART. I have swapped some of the pin numbers and wiring around, so I tried leaving the one driving RST low instead of high and indeed, this seems to be the issue: It's resetting at ~1s intervals.

(I honestly believe I checked this before by removing all connections, but since I did not note that in the question, perhaps I never did...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.