0

tl;dr

I can't send data using the raw SPP-C Bluetooth module without a breakout board. The communication via UART works fine as I am able to issue AT commands and get proper responses. But when connected over Bluetooth the data passed over UART does not show up on my computer while the other direction works fine. Has anyone tried that module yet without using a breakout board?

The long story:

I started my project by using a regular HC-05 module on a breakout board. The prototype worked just fine as there are also plenty tutorials available. The drawback using that breakout module is that it works with two voltages, 5V for power and 3V3 for communication. I have also more components in my project that run best at 3V3. That is why it came to my mind to use 3V3 as the only voltage. The raw HC-05 module without breakout board is also powered with 3V3. So everything looked just perfect.

Looking at the specs to the HC-05 I noticed that there is also more on that module like SPI and USB (page 12 bottom). So I got curious and off track.

Anyway. Instead of ordering raw HC-05 modules without breakout board I ordered cheaper SPP-C modules that don't have all this fancy stuff but just UART communication.

Following the description from Martyn Currey I was quicky able to issue AT commands and receive data over bluetooth. But I am not able to send data over Bluetooth.

I am using the same setup as it is shown on page 4 in the Chinese datasheet. (no I can't read that crazy symbols but I can read and understand the images)

  • This is unanswerable until you clearly document in the body of the question itself what is different between the two cases. Also consider if the computer may be paired to the unique ID of the old module and not the new, or even that the new module might be faulty. – Chris Stratton Jul 31 '16 at 20:48
  • The pairing is not an issue as I can transmit data from my computer. Just the other direction does not work (but works flawlessly with HC-05). I also considered a faulty module so I ordered a SPP-C module on a breakout board for reference. I'll post the results here. – Kwasmich Aug 1 '16 at 6:15
0

I found a solution myself. The modules are working as they are supposed to and are not faulty. Also I did nothing wrong.

The Problem are my development machines. Mac mini (Late 2009) and MacBookPro (Mid 2009), both having a Broadcom 2046 Bluetooth host chip. I used those to connect via Bluetooth and open a tty session using minicom. Running macOS and using "Hardware IO Tools" to log Bluetooth packets I saw that there was clearly nothing coming in.

After that I turned over to my Windows and used Hype! Terminal. Everything worked!

Then I went to my Raspberry Pi and Linux. After pairing using bluetoothctl and issuing a few commands from Bluetooth as ttyUSB. Everything worked as well.

Then I tried BlueSPP on an Andriod phone. And again, it worked as it was supposed to.

So my conclusion is that there is some sort of incompatibility between the SPP-C module and the Broadcom 2046 host controller.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.