1

I just got my Arduino UNO delivered and I wanted to see if it's working properly or not.

I tried following this page to create a simple program and the program compiled successfully.

But when I tried to select the serial port on IDE, the port option was grayed out. I searched for the problem and I landed on this page. It says

Linux includes the drivers necessary to use Arduino, and no additional install is needed. However, permissions might need to be configured. For current instructions on how to set up these permissions, visit this page.

An alternative method is to run Arduino as root in the terminal.

But I still see the port option grayed out even as a root user. Any idea?

  • Have you tried following the instructions in any of the myriad of troubleshooting pages for Linux and Arduino? – Majenko Jul 30 '16 at 13:40
  • @Majenko: Nope. Not yet. Any suggestion? – 7_R3X Jul 30 '16 at 13:42
  • How about doing that thing I just asked if you had done? – Majenko Jul 30 '16 at 13:42
  • Did you check if Linux created a new device in the /dev directory? Did you perform a "tail -f" on the log file of your Linux distribution and watched the output as you plugged in your Arduino? You didn't say which Linux you were using so we can only guess where it keeps it's log file. BTW, you will probably have to have root permissions to look at the log file. BTW, you can check on the permissions of new devices at the same time you are checking on what if anything gets created in the /dev directory. – st2000 Jul 30 '16 at 17:49
  • @st2000 : I'm using Kali Linux and no, plugging in the Arduino doesn't create a new directory in /dev directory. I have the root permission and I tried running Arduino as a root user but the same happens. I do not see any new device/file in /dev. – 7_R3X Aug 1 '16 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.