0

I followed regular tutorial and I was able to burn boot-loader on my standalone ATM328 chip, but because I'm using this CH340 UNO and example is with regular UNO, I can't just remove the chip from there (CH340 UNO) and upload the code directly to my new standalone chip trough that board.

So what I tried was to use my FTDI cable, so I hooked up GND, RX, TX and VCC for my breadboard from there, but when I tried to upload a sketch I keep getting that message that programmer is not responding.

So I was wondering, is there a way to use this Chinese board to upload sketch to my new chip without de-soldering the chip from that board as option one.

As option two what I'm doing wrong with FTDI cable and why I'm not able to upload sketch directly like that? I saw some comments related to some auto-reset that needs to be implemented but I'm not following that part, not sure what I need to hookup extra for that...

UPDATE

Here's how my board look like: enter image description here

Update 2:

OK, everything works great now! I just needed one pull-up resistor for reset pin.

Thanks everyone!

  • you also need to physically connect Reset (RST/DTR) – Wesley Lee Jul 23 '16 at 23:57
  • What is DTR I don't see that pin on my FTDI cable. So that is RTS pin from here ? canadarobotix.com/serial-ttl/ftdi-cable-5v-vcc-3-3v-i-o – ShP Jul 24 '16 at 0:02
  • some FTDI breakouts/cables use RTS, others use DTR. Both ~kinda~ do the same thing: reset your MCU before uploading the sketch. (So the bootloader will know to expect something from the serial port). Note that some breakouts will need a 100nF cap in series with this connection, others wont. – Wesley Lee Jul 24 '16 at 0:08
  • Same thing, I'm still getting the same error. – ShP Jul 24 '16 at 0:16
  • How do you connect DTR or RTS? Did you follow the full guide with pullup resistor and series capacitor? When you switch from one serial device to another, you probably have to point the IDE at the new port, did you do that?? In theory you could use your CH340 board if you hold its onboard ATmega in reset. – Chris Stratton Jul 24 '16 at 0:24
0

You said:

It just need a pull-up resistor for the reset pin!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.