0

So, I recently bought an Arduino Mini (5V, 16MHz), and a USB to Serial Converter. Provided are the links to both the products: Arduino Mini, USB to Serial Converter

Now, I tried programming the mini by connecting the pins in this order: Rx -> tx, tx-> rx, VCC -> 5V, GND -> GND, DTR -> DTR

The computer detected the USB to Serial converter after I installed the drivers manually. However, the Arduino IDE failed to program the Arduino Mini every single time, even after I swapped the TX, RX pins.

I tried to program the Arduino Mini using an Arduino Uno (I removed the onboard Atmel Atmega microcontroller on the Uno before programming). I connected the pins in this order: TX->TX, RX->RX, 5V-> VCC, GND-> GND, RST -> DTR. From the IDE, I chose Arduino Pro Mini (5V, 16Mhz).

The Mini was programmed successfully this time.

My question: What was wrong with the USB to Serial converter? Why couldn't it program the Arduino Mini with the USB to Serial Converter?

  • GND -> 5V; I hope that is a typo? – Gerben Jul 14 '16 at 17:45
  • To test the converter, try connecting the TX on the serial converter to the RX of the same converter. Then in the Arduino IDE open the Serial Console. If you send some text, you should receive the same text back. – Gerben Jul 14 '16 at 17:48
  • I did as you said.. It works.. The converter sends the same text back once I send something... But it still can't program the Mini. – Swapnil Saha Jul 15 '16 at 6:49
  • I had a problem with a USB to Serial convertor. It was because the device I had had a dodgy Chinese clone chip and the real manufacturer changed the driver so it wouldn't work properly unless it was a genuine chip. You can hack the driver inf file to get round it, but I can't remember the details. – Code Gorilla Jul 15 '16 at 12:13
  • The chip on this USB to Serial converter is an Atmel Atmega 8A PU.. – Swapnil Saha Jul 15 '16 at 12:40
1

As you have said the Arduino Mini seems to be fine and the USB to Serial Converter seems to be working too.

This might be a crazy idea but this might work

try connecting the boards like this,

TX -> TX and RX -> RX

I'm not totally sure, but this might work.

0

Try to reset manually just after compiling end

  • I tried.. it doesn't work.... I held the reset button down but the converter still won't program the Mini.... The Mini was programmed using the Arduino Uno successfully btw... It's the converter that is not behaving properly... – Swapnil Saha Jul 16 '16 at 6:07
0

The Mini was programmed successfully this time

If so, one of them had its tx/rx pins mislabeled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.