2

I have an Arduino Uno that I've been programming with an AVR Dragon through Atmel Studio 7.

I did two things in close proximity, and I'm not entire sure which action is the culprit. I tried using the DebugWIRE interface (for the first time) instead of ISP in the tool select screen. I also hit the Arduino's reset button as Atmel Studio was compiling/uploading to the Arduino (stupid, I know.)

Now I cannot program with ISP the normal way, or do anything really. If I try to upload to the Arduino I get:

Enter image description here

I've tried to use the device programming feature using the Dragon and change the fuses as I've read about in other posts and get:

Enter image description here

I've tried burning a new bootloader with the Arduino IDE and the IDE tries ten times, but it tells me that the programmer is not responding.

When I plug my AVR ISP mk2 into a different Arduino Uno I get a nice constant green light. If I plug it into the board I've been discussing it blinks red.

I'm not sure where to go from here...

migrated from electronics.stackexchange.com Jul 7 '16 at 5:12

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

1

I think either the chip or the board is fried. Try swap the chip (only the chip) to the other board and retry loading the program.

  • I swapped the chip from the good board to the bad board and it works. I guess I'll order another atmega328p. How can i determine if the chip is actually fried or just needs reprogramming? I had heard of people forcibly reprogramming a chip after you "goober" it up using hvpp mode with the Dragon. I was reading an article [here][1] that talked about it while trying to debug with dragon which is what i was doing when it happened (as well as resetting the board while atmel studio was programming it). [1]: awtfy.com/2010/02/21/modify-an-arduino-for-debugwire – Khaines0625 Jul 7 '16 at 16:46
  • @Khaines0625 You need something that can perform High Voltage Parallel Programming, which, by applying 12V to RESET pin, bypasses all fuse settings to program the device. You can check out the TL866A (not the CS variant) for this. – Maxthon Chan Jul 8 '16 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.