1

Hey everyone I know this is a pretty common question, and I have read/tried almost everything on all the other posts here and on the arduino.cc forums, but I have been unable to fix my problem. Basically I have been using my Arduino Leonardo for a little over a month now for all sorts of things and have never had this issue with the Arduino not showing up under the port tab on the menu. I have no idea why this just started happening to me, I am using the same cable, etc, and was hoping someone could help me out. I am on a MacBook Pro by the way.

Thanks in advance.

10
  • Does the port appear for a few seconds when you press the reset button? – Majenko Jul 5 '16 at 14:42
  • Okay I just tried, and no it does not. – tyler a Jul 5 '16 at 14:44
  • Does the LED on the board "throb" (fade in and out) when you press reset? – Majenko Jul 5 '16 at 14:44
  • Yes it does fade in and out. – tyler a Jul 5 '16 at 14:46
  • Have you tried a new cable? Or tried the existing cable with another device? How about someone else's computer? – Majenko Jul 5 '16 at 14:50
0

If you have uploaded a sketch that doesn't use the serial port, then after a couple of seconds, the Leonardo won't show up in the ports list.

To upload a new sketch you need to press and release Reset a moment after the upload to the board starts.

2
  • I've been using Leonardos and other ATmega32U4 based boards for years and have never experienced anything like that. – per1234 Aug 2 '17 at 2:26
  • @per1234 - I must admit that I can't reproduce it. – Nick Gammon Aug 2 '17 at 7:08
0

Try this... Go to your Arduino IDE. Under the Tools tab, go to "Board" and select Arduino Leonardo. Then in the Tools tab, go to Port and check to see if a port is selected. Use this link to try and find which Serial Port you should have: https://www.arduino.cc/en/Guide/MacOSX Try plugging in the cable in different USB ports on your computer and see if the port number changes automatically.

Also, could you please say what peripherals or other things are connected to the arduino? Because for example, I know what using a Bluetooth slave with the Arduino while connected with the cable to your computer, doesn't let you upload your program. There could be similar problems to this.

3
  • Yeah so I have the Wireless SD Shield connected to it, but no XBEE Wifi Module. Other than that there is nothing. – tyler a Jul 5 '16 at 15:02
  • I guess you should try disconnecting that before connecting the Arduino to your computer. And try all the USB ports on your computer to make sure they are working. – Lakshya Goyal Jul 5 '16 at 15:03
  • Just tried, still nothing. Also, my restart button no longer flashed the "L" LED, it simply lights it up as long as the button is depressed but no longer... @Majenko – tyler a Jul 5 '16 at 15:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.