Arduino due Programming Port

I'm not able to upload sketch on Arduino Due, using Programming Port.

Even blink sketch from examples is not working. So tried with blank sketch, I got following messages.

  • 2
    Are you sure that the COM port is precisely set?
    – rebatoma
    Jun 22 '16 at 21:51
  • If its not you COM port being set wrong or in use by something else then have you tried the old favourite of uninstalling the IDE and reinstalling it, just in case something has got messed up? Jun 23 '16 at 8:02
  • Upgrade to 1.6.9. There have been a number of changes in the upload system in the recent versions that have both broken and fixed things.
    – Majenko
    Jun 23 '16 at 16:13

Go to device manager, and make sure that you can see the change in your com ports when you unplug and plug the Arduino into your computer.

You may also have to follow the instructions here: https://www.arduino.cc/en/Guide/Cores

I will also occasionally find that uploading won't work when I have something external connected to the RX,TX,3.3 and 5V, and GND pins.

It also helps to go to File-Preferences- and enable both options for "Show verbose output during". If you do that and post the output, we might have a better idea as to what is going wrong.

  • 2
    There is no FTDI chip on a due. How will installing the FTDI drivers help?
    – Majenko
    Jun 23 '16 at 16:08
  • I didn't even see that he was using a DUE! To the OP- if you're using an IDE that's newer than 1.6.2, you may have to follow the instructions here: arduino.cc/en/Guide/Cores
    – Tri
    Jun 23 '16 at 19:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.