-2

I have an unofficial Arduino Uno.

I've tested these:

  • Testing on USB 2.0 and USB 3.0
  • Changing Port (COM XX)
  • Updating drivers for the Unknown device to Arduino Uno (COM XX)
  • Resetting Arduino Board
  • Plug/Unplug
  • 1x PC Reboot
  • Burning bootloader
  • Changing 'Programmer'
  • Uninstalling-Reinstalling device
  • Holding the "Reset" button while I Upload
  • Testing different examples (Blinking/Voltage Serial Read)
  • Testing different "Board" in Arduino software (just in case, you never know)
  • Removing jump wires

Does anyone have any suggestion more than I just tried?

15
  • Which version of Windows are you on?
    – Majenko
    Jun 12, 2016 at 15:16
  • Arduino app is 1.6.9.
    – Eksapsy
    Jun 12, 2016 at 15:37
  • I asked which version of Windows you are using, not which version of the Arduino IDE you are using.
    – Majenko
    Jun 12, 2016 at 15:37
  • Oh man sorry, I was not very careful. Windows 10.
    – Eksapsy
    Jun 12, 2016 at 15:48
  • And what USB chip does your unofficial Uno use?
    – Majenko
    Jun 12, 2016 at 15:56

3 Answers 3

2

The board you have uses the CH340G chip instead of an ATMega16U2 or FTDI FT232R chip.

It requires special drivers, not the ones that come with the IDE.

Why do they use that chip instead of the proper one? Simply because it's dirt cheap. They are the cheapest of the cheapest of the cheapest USB chips around. They frequently die. You might want to save up and invest in a genuine Arduino at some point, because that one may well die out of the blue.

0
1

I had the same problem with the cheap nano from Amazon Longrunner. At first, it worked, I could program it. Then, I farted around with my COM port numbers because I was tired of being in the COM14 area. Since that moment, it stopped working. IDE couldn't find the port COM3. After reading you guys, I also noticed that the device was identified RAMPS which it wasn't before. I updated the driver which didn't work; it told me I was already with latest driver. So I deleted that driver and reconnected my Nano and lord and behold, the new driver USB-SERIAL CH340 installed and everything was fine. El cheapo still works. I don't care to pay more just for the USB chip which I will use only once. The uP is still up to par.

-1

I had the same problem. I was able to upload a simple Blink example, but not my own program. And I thought there's no problem in my program, since I successfully tested it on other Arduino before. But actually, that was the problem. I had this in my program (for console logs):

void setup() {
  Serial.begin(9600);
}

Then I read that different Arduinos use different baud rates. Originally I tested it on Arduino Mega, but this time I wanted to upload it to "unofficial" Arduino Nano (for which you have to use ATmega328P (Old Bootloader) option when uploading).

Since I didn't need debug logs in my program anymore, I removed these 'Serial' commands completely. Then it got uploaded without problems.

A short article on this topic

2
  • so the upload goes to the bootloader, not to your sketch and the baud rate used by the IDE should match the baud rate used by the bootloader. The baud rate set in sketch is irrelevant
    – Juraj
    Oct 1, 2023 at 13:30
  • Later, I got this error for this board even without 'Serial' commands in my program. So maybe there was something more happening. It took me like 20 attempts to upload it to that board again. (Other board worked without problems). So maybe it wasn't actually related :-\
    – juice
    Oct 1, 2023 at 14:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.