0

My Arduino UNO I bought directly from Arduino.cc, so I'm pretty certain it's not a cheap clone. I have a MacBook Pro El Capitan 10.11.5. My Java is 1.8, but I'm pretty sure that doesn't matter. I have never used Arduino before, though I know a good bit of programming and some about computers. Whilst setting up Arduino, the only serial port my computer/Arduino recognizes is /dev/cu.Bluetooth-Incoming-Port. Please comment if there is more information I should provide.

My computer recognizes that I have a USB device as seen here: enter image description here

Here is a screenshot of the Arduino IDE:

enter image description here

Finally, the commandls /dev/tty.* outputs only /dev/tty.Bluetooth-Incoming-Port. Is it possible no other serial ports exist for me? Sorry for the barrage of pictures but I thought they'd help.

Things I have tried:

  1. Installing CH34x driver

I'm convinced it's not a driver issue though, as users and Arduino say that OS X does not need drivers installed to run Arduino

  1. Turning off System Integrity with csrutil --disable and also tried csrutil --enable without kext

  2. Installing a FTDI USB Serial Driver

  3. Bought a new USB A/B cable, as many reported the cable was faulty. I am getting a green light on my board

Does anyone know why my computer and/or Arduino does not list more serial ports that work? It's as if I don't have any besides the one Bluetooth port. I've been getting frustrated over this for several hours, so a solution would be much appreciated :)! I've tried all the solutions I've seen on SE thus far, but maybe I'm missing something

Thank you ahead of time!

1

"ATmega16u2 DFU" indicates a USB interface micro that is in a state to have new firmware downloaded to it (DFU), not one which is ready for operational use as a USB interface to program the Uno's ATmega328p target MCU. If this persists after power-cycling/re-plugging the board, it is probably faulty and at minimum needs firmware repair - though it might be worth trying on another computer (preferably with a different OS or version) just to be absolutely sure nothing in the host software is forcing it to this mode.

If this is a new board you have not modified in any way, you should probably return it as defective.

If you have modified it, or you want to try to fix things yourself, you would need to follow the instructions for reflashing the 16u2 via USB-DFU. Beware that this is a non-trivial task that looks like it is going to require installing macports and running some terminal commands, and on older boards some soldering.

  • Thanks. Kinda comforting that I'm not going crazy. I'll order another one online. I've tried it on Linux, Windows, and Mac and all give the same error! – JKlemm Jun 3 '16 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.