Asking here cause I ran out of options in searching. My Arduino Nano clone isn't recognized by my computer anymore. It was, until I plugged into a Windows machine, that did not recognize it... and now even my Linux Mint distro doesn't detect the Nano at all. Here's the thing, though: the green power LED still lights up and, if I connect my DC motor to it like I used to before, the LED turns off and the motor is powered only a little bit, with less speed than if it were powered by a 1.5V battery.

My voltimeter reads a 2.18V out of the 5V pin.

Here's all I did: uploaded a sketch to power a 5v motor, it worked, unplugged the Arduino, took it home to my Windows machine on the casing I got it from my school, plugged it there, then it didn't detect anything. Go back to the lab today, plug it in, doesn't detect it there either.

From there, I've replaced USB cables, tried different USB ports, checked with lsusb and dmesg, tried finding it using the FTDI tool (the chip underneath is FTDI), then tried powering it from a phone charger, but the voltage readings at the 5v pin still are around 2.18V with that. Nothing seems to give this little thing an output greater than 2.18V. The only thing I haven't tested is powering it through the VIN pin.

I came across other questions of similar problems but nothing that seems quite like mine... since they all either are able to detect the device but it is displayed as an unknown device or can't recognize the device at all but their power LED does not turn on.

Any ideas on what is going on?

  • When powered by a USB port, the 5v should be coming fairly directly from the USB, possibly via a diode. So that suggest a problem with the diode, failure of the connector or PCB or its solder, or an overload (perhaps from a damaged chip) causing the USB VBus itself to sag, or an issue with the measurement itself. May 30, 2016 at 0:45
  • How is/was you motor wired up?
    – Majenko
    May 30, 2016 at 8:12
  • This is why you should not power motors from an Arduino's power supply, regulator, or even simply power nets. Jul 29, 2016 at 4:36
  • Just talking.. Have your flywheel diode been there? Meaning across the Motors terminals? Because if not that might have broke something. Sep 12, 2018 at 11:51

5 Answers 5


It sounds like a blown protection diode MBR0520 in between USB and +5V of the nano.

  • This answer pointed me towards a ton of other people experiencing the same problem (usually after accidentally shorting the 5V and ground pins) and this is exactly what it turned out to be for me as well. It seems to be commonplace with clones. Replacing the diode in question (which protects the USB port in the event of an external power supply also being connected) fixed the problems for me.
    – Xono
    Nov 24, 2018 at 10:14

Apart from 5V pin, the rest sounds like your FTDI clone chip might be bricked. Check your device VID (under Device Manager -> Device Properties -> Details tab -> under Property select Hardware Ids). If VID and/or PID is 0000 than it is.

It is possible restore the original VID/PID (thus recover the Arduino). Google for "Fix bricked FTDI", there are many instructions like this: http://internetofhomethings.com/homethings/?p=987

Most of these cheap Arduino Nano clones have also fake FTDI IC and at some point FTDI (the vendor) released new driver which bricks such clones by setting VID/PID of the chip to 0. This effectively makes the IC undetectable / incompatible with original FTDI drivers. That is why it is not recognized on a PC where it was working earlier.


After recovery, make sure to use older FTDI driver.


What was your schema? did you try to control 5V motor from arduino directly.
Now assuming that

$ lsusb

doesn't show something like:

Bus 002 Device 005: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

It is generaly a bad idea to control any mechanical (magnetic) device without using transistor and maybe a diode to protect against current in an opposite direction
standard DC motors can generate quite a nice voltage if turned mechanically (during transport) or even current increase if motor is blocked when powered.
TO me it sounds like you have burned your chip. USB on most computers has got an over-current protection resulting in lover voltage if something you connect has very low resistance. 2.8volt is more then enough to lit-up green LED on a damage MCU, but probably not to power the FTDI chip wired for 5V


Standards compliant USB ports will only supply 100mA unless a higher current is negotiated by USB.

I suspect that you problem is the USB serial (Chinese Nano clones often have cheap chips). This happened to one of my Nano clones.

  • I'll go to the maintenance lab tomorrow at my school, and see what they tell me. It's rather strange, since this is the second Nano that has some problem on my end. May 30, 2016 at 1:29

It may be caused by the cable. In my case it was. Not all cables have data wires.

  • 1
    The OP indicated that it worked before so... how should the cable change (except mechanical cutting/breaking which would probbly affect other lines too) Apr 18, 2020 at 8:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.