0

I did a bit of playing with my new ESP-12e, but suddenly it kind of fails on me. It gives me some weird looks it didn't give me (as much) before.

enter image description here

This is what the Serial Monitor prints when I try to run a very simple sketch. When I restart the module, it just adds some more of these chars. The following is the code for that:

const int statusLED = 16;

void setup() {
  pinMode(statusLED, OUTPUT);
  digitalWrite(statusLED, HIGH);

  Serial.begin(115200);
  Serial.write("The ESP-12e has started.");
  delay(500);
}

void loop() {
  delay(1000);
  digitalWrite(statusLED, LOW);
  delay(1000);
  digitalWrite(statusLED, HIGH);
}

This doesn't even involve the WIFI...

These are my board settings:
Board: Generic ESP8266 Module
Flash mode: QIO
Flash frequency: 40MHz
CPU frequency: 80MHz
Flash size: 4M (3M SPIFFS)
Upload speed: 115200

And finally, if it might help, how I connected the module:
enter image description here All connections are solid, so that shouldn't be a problem. The connection board has GPIO15 printed on it twice, but the one I connected to the LED is actually GPIO16. I noticed that the onboard LED of the ESP-12e doesn't light on anymore.

I use the CP2102 USB to UART module.

Thanks!
Rogier

  • It seems like maybe the firmware itself is crashing. Have you tried reflashing the device a couple of times? – Malachi May 25 '16 at 16:02
  • The output doesn't appear to be able to have come from your code. Are the states of GPIO[0,2,15] appropriate for booting, at boot time? For running from flash, at run time? – JRobert May 25 '16 at 16:38
  • wow, a negative for that? Problem isn't even solved yet. rough crowd. – Malachi May 25 '16 at 19:13
  • Yes, the GPIO pins should be connected the right way. Also, I am able to upload to the flash memory. – Rogier Reerink May 25 '16 at 19:41
  • Yeah, weird. I don't know who would do that. I will try to flash new firmware and get back to you! Thanks for your help! – Rogier Reerink May 25 '16 at 19:44
1

Check what baud rate is serial window displaying. It should be the same as defined in your code.

|improve this answer|||||
  • Thanks. But that's the same. I have tried other baud rates, but that doesn't change it. – Rogier Reerink May 25 '16 at 14:34
1

NccWarp9 is right, e.g.:

void setup() {
  Serial.begin(115200);

you have to select 115200 in your baud serial monitor option.

it works also for me

(nodemcu 1.0)

|improve this answer|||||
  • 1
    But he already did that. – user31481 Feb 13 '18 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.