-1

I have some Atmega328-Pu micro-controllers without boot-loader program. Now I need to burn boot-loader to them all. I have two arduino uno boards having Atmega328 P-Pu micro-controllers on board. I used this circuit enter image description here from this page Installing an arduino boot-loader It does not work. The boot-loader is not uploaded. Can you please help me out? If you need any more informations please ask. I have been struggling with this kind of boot-loading techniques for more than a week. I am using arduino IDE 1.0.1 and the board is Arduino uno R3

migrated from electronics.stackexchange.com May 25 '16 at 0:20

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

  • Have you uploaded the ArduinoISP sketch to the left-hand Arduino in your diagram and selected ArduinoISP under Tools->Programmer before using Tools->Burn Bootloader to burn the bootloader? BTW, I would strongly recommend upgrading to Arduino 1.6.8 - that is where my instructions are written from. – stefandz May 24 '16 at 12:27
  • This thing has never let me down: arduino.cc/en/Tutorial/ArduinoToBreadboard – Whiskeyjack May 24 '16 at 13:39
  • @Whiskeyjack ... and the Arduino ISP tutorial have never let me down (even with different Arduino types than described in the original tutorial; brief report to that effect). – Nick Alexeev May 24 '16 at 16:15
  • is the target ATmega clock pin oscillating? Is there anything else connected to the SPI pins? – MarkU May 24 '16 at 22:13
  • 1
    After uploading ArduinoISP and before trying to actually burn the bootloader, you have to put a capacitor (10 µF recommended, 1 µF always worked for me) between RESET and 5V of the Arduino on the left (the one running ArduinoISP). – Edgar Bonet May 25 '16 at 7:35
0

Hi friends thanks for your support. It worked well as it is. No external capacitor I used. I made the connection as shown in the above picture taken from LINK1. I modified the file "boards.txt" and "avrdude.conf" as given in step 4 of LINK2 I first uploaded the ArduinoISP sketch to the board on the left. And then I opened an "EMPTY ARDUINO SKETCH". From that empty sketch I made the following changes Tools->Board = "Arduino328" Port = COM4 in my pc Programmer = Arduino as ISP Last step "Burn Bootloader" Ta Da.... It worked. When I posted this question I burnt the boot-loader having the arduino ISP sketch opened. Only thing I changed now is I opened an empty sketch and hit burn from that sketch. Anyway.. thank you all. I dont think I wasted your time. If so, I apologise.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy