1

My quite new Nano clone (ATmega328P + CH340G) suddenly stopped working. Plugging it in with USB did not light up the LED(s) nor did it get detected by my machine. I looked it up, and found some how-to's (such as this one: Repair Arduino Nano (no power on USB)), which suggested at least some diagnostics.

So I plugged the Nano in to a 5V breadboard power source using the Vin and GND pins, and the power LED lights up, but connecting via USB cable to my machine does not detect it.

So then I used some of the methods mentioned in the link, and used just a normal jumper cable (without soldering) to check if that could magically make it detectable by my machine. No luck. I tried bypassing the voltage regulator by "jumping" over it, and the power LED gets brighter, and "pin 13" LED flashes for just an instant. The same occurs if I "jump" the voltage regulator all the way to either end of what I am guessing is the "Schottky diode".

In all cases, still nothing in terms of being detected by my computer. The cable is fine because I tested with another nano clone, and it gets detected right away.

So, how do I properly diagnose what is going on here? Specifically how do I fix my poor board? How do I find which component is in need of replacing?


Update:

I found some online guides on how to have another Arduino board talk to this one over SoftwareSerial and found that I could get some data flowing through. However, the text was garbled, such that, for example if I was expecting it to say:

"Please enter some input"

It might read instead:

"Ulease XYZter some [][]put"

Often with the same characters being garbled in the same way. I tested the Schottky diode the way it was suggested in the video (with some guessing as to the multimeter setting I had to use was, since I have a different model than the one in the video), and it seems the diode is fine. So at this point I am guessing it is the ch340g chip that is toasty, either that, or the ATmega chip itself, which I don't know, but that sounds less likely.

So, could it be that it is the CH340G chip, since I get no power over USB, and the TX/RX over serial is being interfered with? Is there anything else I can do to figure out if it is the CH340G that's damaged before I go about trying to replace it?

  • First you (and we) need a schematic of the board. Without that you're just stabbing in the dark. – Majenko May 1 '16 at 12:03
  • If you can't get one, then you will have to trace the flow of power around the circuit using a DMM. – Majenko May 1 '16 at 12:19
  • Splash out as spend another $2 on a new clone. The same happened to one of my clones and it is still programmable via ICSP. (NOTE before I get any comments no official "Distributor" in Australia stocks genuine Nano.) – Milliways May 1 '16 at 12:20
  • Some clones do not ship with a bootloader. They are basically unusable from the perspective of USB-based programming, until a bootloader is flashed. The only way to do flash a bootloader is to do spi programming, either with a ready-made programmer or with another arduino properly setup. The basic SPI programmer is 5-8 bucks on ebay. – Igor Stoppa May 1 '16 at 14:24
  • Of course you can use another working one as an ISP to flash the bootloader and fuses. Checking the voltage on both sides of the diode is a good idea. Also make sure there are no hairline cracks in the soldering of the surface mount mini-USB connector. The irony is these are often sold for less than the per-piece price of the ATmega! – Chris Stratton May 1 '16 at 20:35
1

Either you have a cable problem or that board is just not working well.

What you call the CH340 chip - when they go bad you get power but NO communications, in my experience. You can test voltages at the various points like 5V, 3.3V, etc., to see if it getting power. If it is and you're still not communicating, then if it were me it would go on the shelf for the kids to see.

It no longer can trusted.

Rather than troubleshooting the board it would be worth getting another to compare with.

And if you have more than one cable on hand, try them and see if there are any differences.

But my prediction is that a new board will work and this one will continue to not work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.